Safari Can't Open Page (Youtube, but Only at School)


pholcidae

New Member
Joined
May 7, 2019
Messages
6
Reaction score
0
Hello. Whenever I try to open Youtube while connected to any of my school's internet (guest wifi, student, etc). I am almost certain it is not blocked by the school, because A. other people can open it just fine, and B. it doesn't say that the website is blocked. It seems to just refuse to load.
Screen Shot 2019-05-07 at 9.51.54 AM.png
Youtube attachments in Discord or Reddit also do not load. I use a MacBook Air 11" from 2014, and am on macOS Mojave (10.14.2). Any help is appreciated.
EDIT: I should add that this happened before I got an Adblocker, and don't think that it is related to the issue.
Screen Shot 2019-05-07 at 9.51.54 AM.png
 
Ad

Advertisements

Cory Cooper

Moderator
Joined
May 19, 2004
Messages
6,944
Reaction score
242
Hello and welcome.

A few troubleshooting questions:
-Is this a school provided Mac? If so, did they lock the Network preference pane?
-Can teachers access YouTube, but not students?
-Have you tried another browser like Google Chrome?
-Have you tried to Clear History in Safari?
-You could try updating to macOS Mojave 10.14.4

C
 

pholcidae

New Member
Joined
May 7, 2019
Messages
6
Reaction score
0
Thanks for the reply.
This is my personal computer, and have had it for a while now. (I have been able to use YouTube up until about halfway through this year)
All the teachers and most of the other students can access it just fine. A friend with a razer has told me that they can’t get on YT either, but I haven’t had time to see if it was a similar issue.
I have tried Firefox, but not chrome.
I will try clearing my history tomorrow, and if that doesn’t work I will update the computer and go from there. Thanks for the suggestions.
 

Cory Cooper

Moderator
Joined
May 19, 2004
Messages
6,944
Reaction score
242
No problem.

Also, if your school account is a Google account, try using Chrome and signing into Chrome with your school account - that logs you into YouTube as well.

Let us know how it goes,

C
 

pholcidae

New Member
Joined
May 7, 2019
Messages
6
Reaction score
0
I cleared my history and tried it, nothing changed. I will update the os overnight and try tomorrow.
 

pholcidae

New Member
Joined
May 7, 2019
Messages
6
Reaction score
0
Alright, wasn't able to Friday but I updated it today and nothing has changed.
 

pholcidae

New Member
Joined
May 7, 2019
Messages
6
Reaction score
0
Thanks, I will try that list tomorrow (or Wednesday, I have an AP test in the morning and might leave after).
I usually use [school]_HELP because very few people know the password and it is generally faster, but this issue happens on [school]_STUDENT and [school]_GUEST as well. What network settings would I check?
 
Ad

Advertisements

pholcidae

New Member
Joined
May 7, 2019
Messages
6
Reaction score
0
I also tried the fixes on that list, nothing there worked either.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top