Problems with Google Files opening with Safari

Joined
Apr 4, 2019
Messages
39
Reaction score
1
Started a few days ago.

I use Google Chrome exclusively on my Macbook pro and my iMac.
Now, if I click on a desktop link it has started opening in Safari, even though they were all created with Google Chrome.
This is happening on both computers.
My default browser is Google Chrome.
When I use ‘Get info’ ' it says 'Safari (default)' blanked out.
All my links now say this in 'Get info'??
When I unlock the ‘Get info’ the Safari default stays blanked out.
I have not used Safari for years.
On my MacBook ‘get info’ there is know default setting at all.
My bookmarks work in the normal way.
It is just web sites that I have pulled onto my desktop from Goole Chrome browser.

I am on Ventura 13.1
 
Joined
Feb 14, 2021
Messages
986
Reaction score
130
Started a few days ago.

I use Google Chrome exclusively on my Macbook pro and my iMac.
Now, if I click on a desktop link it has started opening in Safari, even though they were all created with Google Chrome.
This is happening on both computers.
My default browser is Google Chrome.
When I use ‘Get info’ ' it says 'Safari (default)' blanked out.
All my links now say this in 'Get info'??
When I unlock the ‘Get info’ the Safari default stays blanked out.
I have not used Safari for years.
On my MacBook ‘get info’ there is know default setting at all.
My bookmarks work in the normal way.
It is just web sites that I have pulled onto my desktop from Goole Chrome browser.

I am on Ventura 13.1
Maybe you have your default browser set to Safari in System Settings? System Settings > Desktop & Dock > Default web browser

This usually supersedes the default setting made from within the browser itself.
 
Joined
Apr 4, 2019
Messages
39
Reaction score
1
Sadly, that would be too easy tony.
Screenshot 2023-01-20 at 14.24.45.png
 
Joined
Feb 14, 2021
Messages
986
Reaction score
130
Sadly, that would be too easy tony.
View attachment 4578
Does the link file have a “.webloc” extension? When you right-click on the file, what comes up on top on the list of Open With? You may have to rebuild launch services. You can also try choosing Chrome by getting info on the .webloc file. However, I tested this in Ventura 13.2 and the Open With selection is grayed out, only displaying my default browser, Safari Technology Preview.
 
Last edited:
Joined
Apr 4, 2019
Messages
39
Reaction score
1
This is a 'get info' from a BT performance Test web site.
You will note the 'open with' Safari - greyed out.Screenshot 2023-01-20 at 16.12.48.png
 
Joined
Apr 4, 2019
Messages
39
Reaction score
1
The weird thing is that I have the same problem on my Macbook pro - also Ventura 13.1
Both started a few days ago???
 
Joined
Feb 14, 2021
Messages
986
Reaction score
130
The weird thing is that I have the same problem on my Macbook pro - also Ventura 13.1
Both started a few days ago???
Unfortunately, it’s no different in macOS 13.2. As I mentioned before, a reset of launch services might work. I will try it next chance I get. However, I’m able to launch Chrome when I right-click on the .webloc file and select Chrome in the Open With selection.
 
Joined
Apr 4, 2019
Messages
39
Reaction score
1
Yes.
That works for me too.
So what is causing this and how can we change the Safari default Tony?
 
Joined
Feb 14, 2021
Messages
986
Reaction score
130
Yes.
That works for me too.
So what is causing this and how can we change the Safari default Tony?
I tried the cure-all procedures—SMC reset, PRAM zap, Safe Boot… No joy either. I will later try resetting Launch Services although I did that not too long ago; but first I want to boot into Monterey and see if the same thing is happening. It seem like, so far, the only file that cannot be set to “open with” in Get Info is .webloc.
 
Joined
Apr 4, 2019
Messages
39
Reaction score
1
I tried the cure-all procedures—SMC reset, PRAM zap, Safe Boot… No joy either. I will later try resetting Launch Services although I did that not too long ago; but first I want to boot into Monterey and see if the same thing is happening. It seem like, so far, the only file that cannot be set to “open with” in Get Info is .webloc.
Thanks Tony - Good luck!
I wait with baited breath.
 
Joined
Feb 14, 2021
Messages
986
Reaction score
130
Thanks Tony - Good luck!
I wait with baited breath.
Same problem/anomaly in Monterey. I also did a PRAM and SMC reset. Then ran maintenance tasks via Onyx, including Launch Services and Spotlight index. In the end, Finder Get Info is still unable to change Open With for .webloc files, even after unlocking the Get Info window. The only way I can think of to open Web internet connection files is through right-click and selecting open with and choosing the browser of your choice.
 
Joined
Feb 14, 2021
Messages
986
Reaction score
130
This is going to sound silly. In spite of the fact that Get Info on the web location file (.webloc) shows Safari in the Open With setting, a double click on the file itself will indeed launch MY chosen default browser. In your case, if you want Chrome to open the file, make it your default browser in System Settings. (I temporarily changed mine to Chrome, and sure enough it launched Chrome, while Safari was still showing up as Open With in Get Info.) Try it, by setting your default browser, Chrome, in System Settings.

I think it was all much ado about nothing. Finder will choose your default browser in spite of all the other indications. At least that is what happens on my setup.
 
Joined
Apr 4, 2019
Messages
39
Reaction score
1
This is going to sound silly. In spite of the fact that Get Info on the web location file (.webloc) shows Safari in the Open With setting, a double click on the file itself will indeed launch MY chosen default browser. In your case, if you want Chrome to open the file, make it your default browser in System Settings. (I temporarily changed mine to Chrome, and sure enough it launched Chrome, while Safari was still showing up as Open With in Get Info.) Try it, by setting your default browser, Chrome, in System Settings.

I think it was all much ado about nothing. Finder will choose your default browser in spite of all the other indications. At least that is what happens on my setup.
My default browser has always been Chrome for many years on my Mac.
That was the first thing I checked.
They always wake up Safari no matter how many clicks I give it.
I looked on the internet last night and this problem has been going on for at least 2 years, so I am not alone.
The real question is why can't we change the 'open with' setting?
There must be something wrong.
That is where the problem is.
Obviously people who use Safari will have no problem.
 
Joined
Feb 14, 2021
Messages
986
Reaction score
130
My default browser has always been Chrome for many years on my Mac.
That was the first thing I checked.
They always wake up Safari no matter how many clicks I give it.
I looked on the internet last night and this problem has been going on for at least 2 years, so I am not alone.
The real question is why can't we change the 'open with' setting?
There must be something wrong.
That is where the problem is.
Is your Chrome setting done in Chrome’s preferences? I didn’t have Chrome set as default in Chrome’s preferences. I made the setting in Ventura’s System Settings, nowhere else. I did not make Chrome default in Chrome’s settings. And immediately, when I double-click on the .webloc file, Chrome opens and goes to that URL.

I understand your frustration if this does not work for you. I’m having an issue with Clock Settings when I set it to announce the time every 15 minutes. It works for the present but then is turned off if I reboot or simply log out and in again. The mystery here is that when I make the exact setting on an external Ventura disk, same Mac, the setting is always preserved, even after a reboot. I still haven’t figured it out myself, and neither have the Apple team. I had been reporting this issue all throughout the beta testing period of Ventura.
 
Last edited:
Joined
Apr 4, 2019
Messages
39
Reaction score
1
Is your Chrome setting done in Chrome’s preferences? I didn’t have Chrome set as default in Chrome’s preferences. I made the setting in Ventura’s System Settings, nowhere else. I did not make Chrome default in Chrome’s settings. And immediately, when I double-click on the .webloc file, Chrome opens and goes to that URL.

I understand your frustration if this does not work for you. I’m having an issue with Clock Settings when I set it to announce the time every 15 minutes. It works for the present but then is turned off if I reboot or simply log out and in again. The mystery here is that when I make the exact setting on an external Ventura disk, same Mac, the setting is always preserved, even after a reboot. I still haven’t figured it out myself, and neither have the Apple team. I had been reporting this issue all throughout the beta testing period of Ventura.
I am set to Chrome on both Ventura & Chrome.
 
Joined
Feb 14, 2021
Messages
986
Reaction score
130
I am set to Chrome on both Ventura & Chrome.
What led me to the “solution,” in my case, is that Finder’s Open With is Safari, which is greyed out so you cannot change it. Normally .webloc will open with Safari Technology Preview (my System Settings default browser). So why did it open with my preference and not with Safari? So I changed my setting (in System Settings) to Chrome but did nothing to Chrome’s setting.

Double-clicking the file then opened in Chrome! I realized that the “Safari” setting in Finder had nothing to do with it. It had to do with my choice of browser in System Settings > Desktop & Dock > Windows & Apps > Default web browser. Make your choice here, not in the browser preferences—at least for opening web links. If this does not work, try making Chrome NOT your default browser, temporarily.

Your mileage might vary, as evidenced by my enigma with Clock Settings that I wrote about.
 
Joined
Apr 4, 2019
Messages
39
Reaction score
1
As I said I am on Google in Ventura.
I selected another search engine instead of Chrome, in the Chrome settings
but it made no difference.
I am happy that I can select a browser in the 'get info' box so that is good.
However I don't like unsolved mysteries, as to why we cannot alter the greyed out browser.
It only started with me a few days ago - why??

Screenshot 2023-01-21 at 20.26.39.png
 
Joined
Feb 14, 2021
Messages
986
Reaction score
130
As I said I am on Google in Ventura.
I selected another search engine instead of Chrome, in the Chrome settings
but it made no difference.
I am happy that I can select a browser in the 'get info' box so that is good.
However I don't like unsolved mysteries, as to why we cannot alter the greyed out browser.
It only started with me a few days ago - why??

View attachment 4580
You and me, both. I’m still going crazy over my Announce the time setting with no solution in sight. And not being frivolous with this. Ever since the Mac G4 days, I always had my Mac announce the time every half hour to remind me to take a one-minute squat break to keep the blood flowing.
 
Joined
Apr 4, 2019
Messages
39
Reaction score
1
You and me, both. I’m still going crazy over my Announce the time setting with no solution in sight. And not being frivolous with this. Ever since the Mac G4 days, I always had my Mac announce the time every half hour to remind me to take a one-minute squat break to keep the blood flowing.
It gives us something to think about Tony.
Thank you for all your effort and interest.
Nobody else seems to have any idea either.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top