MacBook Pro Mid 2009 won't boot, detect USB and can't reinstall OS on new SSD


Trevstonbury

New Member
Joined
Oct 18, 2019
Messages
1
Reaction score
0
Good morning,

I’m hoping someone can help me. I have a MacBook Pro Mid 2009, it’s no longer booting properly from the existing hard drive and just gets stuck at the loading screen and eventually reboots in a loop. Ive tried all sorts of things to repair it, as well as replacing the Hard drive with a Crucial MX500 SSD but nothing is working properly.

I suspect the current disk is failing, I can boot it into recovery mode but have only been able to run first aid on the disk once which failed. I’ve also gone in through safe mode to run the various verify and fsck-fy commands which are failing – so I think it’s a bad disk

Carried out PRAM & SMC Resets which have made no difference

I have replaced the hard drive with the SSD which at first wasn’t detected until I formatted it. Then I used TransMac with an El Capitan image, restored the image to a USB drive in an attempt to boot into recovery mode and install using the new image onto the new SSD, which fails to work.

Firstly, it won’t boot into recovery mode, I’m guessing it’s because there is no recovery mode available as it was on the old HDD and this older Mac has no internet recovery option. When I use the ‘Option’ key at boot to select a boot device it only detects the blank SSD, it doesn’t detect the USB. In fact, it doesn’t detect any external drive I've used with TransMac or a DVD with El Capitan on. The only USB drive it detects is a Transcend external USB which was used for time machine backups but as I can’t get into recovery mode with the new SSD I can’t restore it. When I've tried restore from time machine backup with the old hard drive in, no backups are detected. I’m not sure why it only picks up the Transcend drive…

I’ve tried to get into hardware diagnostics mode using ‘D’ but that doesn’t work
I’m really at a loss with what to try next, if I can’t get the MacBook the install media I can’t think of a way to reinstall on the new SSD.

Bit of background info, I don’t have a spare Mac or Apple device, Only a Windows 10 computer. Any help would be much appreciated!!

Kind regards

Trevor
 
Ad

Advertisements

Cory Cooper

Moderator
Joined
May 19, 2004
Messages
7,501
Reaction score
266
Hello and welcome.

Macs introduced before June 2013 use Apple Hardware Test (AHT), noit Apple Diagnostics. You should still be able to startup using the D key to enter AHT, but make sure you keep holding it until you see the AHT icon. If that doesn't work, try holding Option-D:
How to use Apple Hardware Test on your Mac

You should also be able to use Internet Recovery...try using Command-Shift-R if Command-R doesn't work:
About macOS Recovery
How to reinstall macOS from macOS Recovery

As far as a Time Machine restore, you may need to get a fresh install of the same version of OS X/macOS on the SSD before you can restore your Time Machine backup. You may be able to visit an Apple Store and have them install El Capitan on the SSD for you. Do you have one close to you?

C
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top