MacBook Air 2017 internet/wi-fi weirdness


ADR

Joined
Feb 13, 2022
Messages
1
Reaction score
0
***Apologies for length but this has gone on a while, lots has happened and this seems like essential context***

My MacBook Air 7.2 13" 2017,Dual Core Intel Core i5, running on Monterey, updated today.

A few months ago we upgraded our wi-fi type to a DIA signal. We got a good router to help with that - ASUS RT-AX300 and the internet company guys set everything up one-time.
After that we started having strange issues on all devices as suddenly one would loose internet and an alert - "incorrect password" - would appear. We'd input password and sometimes it would work, sometimes it would be wrong. If wrong, same password with upper case would work. Next time it happened you'd try with upper case and it wouldn't work, but lower case would.
At some point, my MacBook Air started not just asking for a password, it would lose signal and then not even see a signal. WiFi symbol on top line would have a line through it and would say Wi-Fi is off.
In Network Prefs I could see WiFi in my list of options (Thunderbolt Bridge, VPN etc) but it would also say WiFi was off.
Over the weeks I've removed the WiFi option (with - sign) and re-added it (+) numerous times.
I've renewed DHCP Lease.
I've manually entered TCP/IP info - IPv4, subnet mask etc. addresses of the router in the Advanced section.
Have added DNS server numbers for the router and even tried generic ones from Google (8.8.8.8. etc).
I've also deleted specific PLists from Library - Preferences - System Config ... several times, hoping it would shake hands with the signal and forget all the bad blood between us.
Occasionally these worked, for a time.

BUT most often, I would restart after trying one of the above and it would have an exclamation mark through the WiFi symbol on top bar, offering me Turn WiFi On (unresponsive if I tried) and Network Preferences.
If I try to open Network Prefs it comes up with an alert - Network Preferences cannot be opened due to an error.
So I restart and see if it will come back with a signal on re-boot.
Sometimes. Not usually.
If I leave it off for a few hours and turn it back on it might work, but often not. I can see the WiFi is searching for a signal as it reboots but very often switches to exclamation mark or the crossed-out WiFi symbol.

This cycle continued and I:
- took it to a technician who said Airport card was fine, he cleaned some corrosion off its connector and it worked fine in the shop. Back home, back to same cycle as before, unable to connect.
- bought an ethernet to thunderbolt adapter. Was a able to log in to router, most times. BUT sometimes MBA won't recognise the ethernet connection either! On one occasion it suddenly came on and I had a connection.
- sometimes, when I can open Network Prefs, I can remove the WiFi option but when I try to create a new one with the + sign, it doesn't offer me any WiFi. Just Thunderbolt, VPN,PPoe and some others.
Other times the ethernet is giving me a signal, as I can see in Network Prefs, but if I click on to the WiFi option in there, it crashes Network Prefs.
- when online I can access the router. It's an ASUS RT-AX300 which is dual band, 2.4ghz and 5ghz. I've figured out that technicians who set it up gave one of those a lower case password and the other has same password with upper case! This explains why we all had the sudden "invalid password" alerts as it switches between signals.

My MBA seemed to work again. Thunderbolt and WiFi options in NPrefs, signal on both etc.
Next day, back to same old problem.
As it happens, I'm typing this on MBA because its working normally now. But I guarantee it'll go weird again because the inconsistency is part of the issue.

NOTE: MBA also had problems connecting to printer wifi a while back, before all this started. Printer was fine - printed everything via my phone because I couldn't resolve MBA-printer issue. This was before our new DIA signal was installed.

After all this, I'm pretty sure all this is a problem with the MBA and not with the signal/router - but would love to hear thoughts on this
Is there a way of re-setting the WiFi card or some other internet-controller on the MBA?
BTW I've tried all the obvious diagnostic stuff - resetting PRAM etc., Apple Hardware Diagnostics, Wireless Diagnostics, built in Disk Utility etc. Nothing shows up.

Any thoughts would be very welcome!
 
Last edited:
Ad

Advertisements

Cory Cooper

Moderator
Joined
May 19, 2004
Messages
10,661
Reaction score
457
Hello and welcome.

Sorry for the delayed response.

I assume you mean you upgraded your ISP connection to a Dedicated Internet Access (DIA) connection or Fixed Wireless? I don't have much experience with that other than the multiple fiber connections at work.

A few troubleshooting questions for you:
  • What type of encryption are you using for your Wi-Fi - WPA, WPA2, WPA3, etc.?
  • Have you tired disabling Wi-Fi 6 on the router?
  • Is your MBA using DHCP or a static IP, or an IP reservation from the router?
  • Is the MBA the only device having the issue?
  • Have you tried completely removing the Wi-Fi network(s) in the Network preference pane, as well as all entires in Keychain Access?
  • Does the MBA have the same issue when connected to a Wi-Fi network outside your location?
  • Have you tried connecting your MBA to an iOS device using Personal Hotspot to see if it maintains a connection?
There isn't any way to reset the Mac's networking hardware directly, other than an NVRAM/PRAM and SMC reset.

C
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top