LAN Network issue, No reponse on 127.0.0.1

Discussion in 'Networking' started by Congregate, May 19, 2016.

  1. Congregate

    Congregate New Member

    Joined:
    May 19, 2016
    Messages:
    2
    Likes Received:
    0
    Hello everyone



    I am experiencing some issues on my LAN network from my mac book pro. I am trying to connect to LAN servers on various different pieces of software running on different machines but my mac is unable to pickup and connect to the external servers on 127.0.0.1.

    I have the suspicion that it could be something to do with my localhost connection. I cannot connect to 127.0.0.1 when I use “Ping 127.0.0.1” or “Ping Localhost”, it returns nothing.

    Further information;
    I can connect to the internet fine.

    I have a default hosts file

    I have disabled my firewalls and my little snitch program

    I am running a Mac book pro on OSX Mavericks 10.9.2

    Here are a few commands that I have found from other support threads that could be relevant in diagnosing the problem,



    Dig localhost

    ; <<>> DiG 9.8.3-P1 <<>> localhost
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 11015
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0



    ;; QUESTION SECTION:
    ;localhost. IN A



    ;; ANSWER SECTION:
    localhost. 0 IN A 127.0.0.1



    ;; Query time: 3 msec
    ;; SERVER: 192.168.1.1#53(192.168.1.1)
    ;; WHEN: Thu May 19 22:48:02 2016

    ;; MSG SIZE rcvd: 43


    ifconfig


    lo0: flags=8149<UP,LOOPBACK,RUNNING,PROMISC,MULTICAST> mtu 16384
    options=3<RXCSUM,TXCSUM>
    inet6 ::1 prefixlen 128
    inet 127.0.0.1 netmask 0xff000000
    inet6 fe80::1%lo0 prefixlen 64 scopeid 0x1
    nd6 options=1<PERFORMNUD>
    gif0: flags=8010<POINTOPOINT,MULTICAST> mtu 1280
    stf0: flags=0<> mtu 1280
    en0: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500
    options=10b<RXCSUM,TXCSUM,VLAN_HWTAGGING,AV>
    ether a8:20:66:48:03:bd
    nd6 options=1<PERFORMNUD>
    media: autoselect (none)
    status: inactive
    en1: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500
    ether 5c:96:9d:82:39:93
    inet6 fe80::5e96:9dff:fe82:3993%en1 prefixlen 64 scopeid 0x5
    inet 192.168.1.156 netmask 0xffffff00 broadcast 192.168.1.255
    nd6 options=1<PERFORMNUD>
    media: autoselect
    status: active
    en2: flags=8963<UP,BROADCAST,SMART,RUNNING,PROMISC,SIMPLEX,MULTICAST> mtu 1500
    options=60<TSO4,TSO6>
    ether d2:00:11:e3:c2:80
    media: autoselect <full-duplex>
    status: inactive
    fw0: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 4078
    lladdr 10:dd:b1:ff:fe:1e:3c:28
    nd6 options=1<PERFORMNUD>
    media: autoselect <full-duplex>
    status: inactive
    bridge0: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500
    options=63<RXCSUM,TXCSUM,TSO4,TSO6>
    ether aa:20:66:84:8d:00
    Configuration:
    id 0:0:0:0:0:0 priority 0 hellotime 0 fwddelay 0
    maxage 0 holdcnt 0 proto stp maxaddr 100 timeout 1200
    root id 0:0:0:0:0:0 priority 0 ifcost 0 port 0
    ipfilter disabled flags 0x2
    member: en2 flags=3<LEARNING,DISCOVER>
    ifmaxaddr 0 port 6 priority 0 path cost 0
    nd6 options=1<PERFORMNUD>
    media: <unknown type>
    status: inactive
    p2p0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 2304
    ether 0e:96:9d:82:39:93
    media: autoselect

    status: inactive

    P.S there is not any information in that code that people could use for malicious attacks is there and If there is could you be kind enough to let me know?

    Thank you,

    A
     
    Congregate, May 19, 2016
    #1
    1. Advertisements

  2. Congregate

    Cory Cooper Moderator

    Joined:
    May 19, 2004
    Messages:
    6,044
    Likes Received:
    199
    Hello and welcome.

    127.0.0.1 is the loopback IP address of localhost, and can only be connected to only on the computer you are currently logged into and are using. You cannot connect to 127.0.0.1 on another computer on the LAN. In effect, it is the IP address of the computer you are using.

    If you use the ping function in Network Utility on the machine you are currently using, and enter 127.0.0.1, it should return pings of less than .25 ms. Same goes for the ping 127.0.0.1 command in Terminal. Your dig localhost command also looks correct.

    -What kinds of LAN issues are you having?
    -How and for what reason are you trying to connect to other servers on your LAN?
    -Are you issuing those commands in Terminal?

    C
     
    Cory Cooper, May 19, 2016
    #2
    1. Advertisements

  3. Congregate

    Congregate New Member

    Joined:
    May 19, 2016
    Messages:
    2
    Likes Received:
    0
    Hello Cory

    Thanks for the reply

    I have solved my issue by deleting my .plist files in ~/Library/preferences

    Regards,

    A
     
    Congregate, May 20, 2016
    #3
  4. Congregate

    Cory Cooper Moderator

    Joined:
    May 19, 2004
    Messages:
    6,044
    Likes Received:
    199
    No worries...glad you resolved it ;)

    C
     
    Cory Cooper, May 20, 2016
    #4
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.