Key repeats with new non-mac keyboard


jonoville

New Member
Joined
Aug 30, 2018
Messages
2
Reaction score
0
HELP!
I just* bought a* new Cool* Master Pro S keyboard to use with my iMac computer running High Sierra.

The problem is the key repeats are way too fast so I wish to turn them off. (on the original mac keyboard i didn't use key repeats at all"

I tried the control in the iMac System Preferences/keyboard settings but, with this keyboard, there seems to be no change..I can't turn keyboard repeat off or slow it down making it impossible for me to type anything without letters continuously repeated.

When plugging the keyboard in, though it does work, when trying the 'recognize keyboard' selection in the keyboard settings it doesn't seem to recognize this one which may be the problem. ???
Any help would be appreciated

Thanks
 

Cory Cooper

Moderator
Joined
May 19, 2004
Messages
6,850
Reaction score
237
Hello and welcome,

Did you try setting the repeat rate with the keyboard itself as stated in the manual:
FN + F5 = Repeat Rate 1X
FN + F6 = Repeat Rate 2X
FN + F7 = Repeat Rate 4X
FN + F8 = Repeat Rate 8X

I would try FN + F5 = Repeat Rate 1X, then see if the Keyboard preference pane will slow it down from there. Unfortunately, there doesn't seem to be a Mac version of the Cooler Master Portal software.

C
 
Ad

Advertisements

jonoville

New Member
Joined
Aug 30, 2018
Messages
2
Reaction score
0
Thanks for the reply Cory & sorry for the delay.

I did try those keys but they didn't seem to have any effect at the time but I did solve the problem in the end.

What I found is if I went into disability section... 'System Preferences/accessibility/Keyboard/Enable slow keys' That did the trick and then I could put your initial suggestion to use.

All happy now.

Cheers
Jon. :)
 

Cory Cooper

Moderator
Joined
May 19, 2004
Messages
6,850
Reaction score
237
No worries.

Excellent that you found a workaround...and thanks for posting, as it may help others in the future.

Be well,

C
 
Ad

Advertisements

oldbilljr

New Member
Joined
Sep 26, 2018
Messages
4
Reaction score
0
I replaced my Apple mouse with a wired Belkin and discovered you must go to Accesibility in the System Preferences and make sure 'Enable Mouse Keys' is Off.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top