Keyboard shows up the wrong characters


John Emmas

New Member
Joined
Jun 12, 2017
Messages
56
Reaction score
0
I recently bought a Mac Pro for use in the UK. It came installed with Mojave and I'm using a non-Apple keyboard (standard 102 keys). I've checked that my Region is set correctly - but regardless of whether I select "British" keyboard or "British PC" it always gives me an @ sign instead of double quote marks (and vice-versa). Is there any way I can reverse those actions so that I get the correct characters?

I have an older Mac Mini here (still at about Yosemite) which doesn't give this problem so I must have solved it at some time in the past - I just can't remember how...
 

Lufbrarunner

New Member
Joined
Jan 25, 2017
Messages
348
Reaction score
16
I have both British and British-PC available in Keyboard Preferences > Input Sources and Show input menu in menu bar enabled. I can switch between the two options by clicking on the icon in the menu bar (Top right) and selecting the appropriate option from the drop down menu. British - PC would be the option you require.
 
Ad

Advertisements

John Emmas

New Member
Joined
Jun 12, 2017
Messages
56
Reaction score
0
Ah - I'd forgotten that I actually need to select it in my Menu Bar. Thanks Lufbrarunner, that's fixed the problem.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top