Gmod crash


Treybird27

New Member
Joined
May 10, 2014
Messages
2
Reaction score
0
I've been playing gmod while on my mac now. Sometimes it works and ill be able to play for 3-4 hours before crashing, and sometimes it crashes on start and i cant play at all? Any Advice anyone? Has anyone had this problem before? . Thanks for any help!
Link the crash report : http://pastebin.ca/2737914

Update: reinstalled and having same problem
 
Last edited:

oldscribe

New Member
Joined
Nov 14, 2012
Messages
1,941
Reaction score
74
Hi,

Seems to be a lot of posts on steam community about this. Solution seems to be fully uninstall Gmod then reinstall.
 
Ad

Advertisements

Ad

Advertisements

SamuTheFrog

New Member
Joined
Aug 8, 2014
Messages
13
Reaction score
0
<--- Gmod Professional here.

I'll be honest man, Source Engine isn't exactly the most stable, regardless on if you're running on Windows or OS-X, but if I have learned anything in my years of GMod...

Keep your addons under 40. 40+ addons do cause issues with compatibility, insufficient RAM, VRAM, etc. As they are quite the RAM whores...

Go to Steam Library>Right click Garry's Mod>Properties>Local Files(the Tab)>Verify Integrity of Game Cache. Let it verify, when it Finishes, be sure to restart steam or it won't apply, then run Garry's Mod and see if anything has changed.

Now, when you "Unsubscribe" from addons in the workshop, it actually doesn't delete the addons from Garry's Mod, it simply stops them from updating... So be sure that when you want to get rid of addons, go to Finder>Go(On the bar on the top by default)>Computer>Macintosh HD(By default)>[Username]>Library>Application Support>Steam>SteamApps>Common>GarrysMod>Addons and remove the .gma's and send them to trash bin, otherwise those addons will never technically leave Garry's Mod. Thus still causing errors, compatibility conflicts, etc. Then again, restart Steam, or they will just reappear in the folder as soon as you run Garry's Mod again.

If all this fails, it is probably due to an insufficient GPU. CPU is out of the question... It doesn't require much. GPU however, it needs a lot of VRAM for it to run without issues - at times. If this is the case, simply lower graphic settings a little bit... More specifically Post Processing, Anti-Strophic Filtering, Water Detail(Water textures in Garry's mod can be GPU whores at times) and Shadow Quality. DO NOT lower your model detail and texture detail as this will likely cause missing textures and missing models with A LOT of models and maps not native from Source Engine.

Anyways, good luck man, hope this works. It should but knowing Source Engine... There isn't a fix. These are just things I've learned through the years that do fix some issues.

Should you have any questions, you can find me on Steam.

http://steamcommunity.com/id/SamuTheFrog22

- SamuTheFrog
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top