External hard drives no longer mounting


Joined
Apr 23, 2016
Messages
1
Reaction score
0
Hi guys,

While fixing my 13” (2013) Macbook Air’s wifi problems (which had been going on for 2 years), I ended up creating a new problem for myself.

I was getting constant connection dropouts at home and speeds that make 56K dial up look like ADSL so I tried solutions that I found from a couple forums that appeared to fix their issues:

- I downloaded Kext Wizard and installed the Kext and went to maintenance and ran the permissions repair (yes I made a backup of the original)

- I downloaded Kext Utility and ran it and installed the Kext named ‘IO80211Family.kext’​

I know, I probably shouldn’t have ran both apps but the first one didn’t appear to work so I tried the other.

Eventually my wifi issues actually did get resolved but I’m not even sure if it was from these Kext apps as I also changed some router settings. Anyway I was happy as heck when my wifi was seeing normal speeds for the first time in 2 years, however, when I went to plug in my 1TB Toshiba Canvio portable hard drive I found it did not show up anymore.

I then tried just a regular USB stick and that didn’t show up anymore either!

I found that they do show up in Disk Utility but the drive’s name is grayed out and when I attempt to mount it, I get an error message (“Mount failed - The disk “EXTHARDDRIVE” could not be mounted. Try running First Aid and then retry mounting.”)

So then I do a ‘Verify Disk’ on the external hard drive and there are no errors. I do a ‘Repair Disk’ on the external hard drive and there are no errors either.

But when I go to mount the drive it again comes up with the same error…

Solutions I’ve tried that didn’t work:

- Disk Utility verify and repair on both my own hard drive and the external drive

(When I click on Macintosh HD and click ‘Verify Disk’ it comes up with an error message “Alert - Couldn’t mount disk.” and the same thing happens when I try to repair)

- Resetting the PRAM

- Resetting the SMC

- Unplugging everything and restarting the computer

- My preferences in Finder are set to show external hard drives on desktop and in Finder

- Attempting to mount via Terminal​


Things to note:

- I am able to get the external hard drive to mount only when I boot up in Recovery Mode

- The drive is formatted as a FAT

- The external hard drive works on my brother’s Macbook Air​

I'm guessing it must have something to do with the Kext installation that I was messing around with.
So after spending 12 hours of the last 3 days trying to fix this issue I am tapped out and I think I need some assistance :(

Anyone got any ideas?
 

Attachments

  • Screen Shot 2016-04-23 at 8.28.58 pm.png
    Screen Shot 2016-04-23 at 8.28.58 pm.png
    68.5 KB · Views: 295
  • Screen Shot 2016-04-23 at 8.25.57 pm.png
    Screen Shot 2016-04-23 at 8.25.57 pm.png
    152.2 KB · Views: 300
  • Screen Shot 2016-04-23 at 8.25.43 pm.png
    Screen Shot 2016-04-23 at 8.25.43 pm.png
    138.3 KB · Views: 293
  • Screen Shot 2016-04-23 at 8.24.01 pm.png
    Screen Shot 2016-04-23 at 8.24.01 pm.png
    115.8 KB · Views: 281
Ad

Advertisements

Cory Cooper

Moderator
Joined
May 19, 2004
Messages
10,749
Reaction score
464
Hello and welcome.

-Which version of OS X?
-Do you have any form of current Time machine or other backup of your data?
-Is there a reason you left the external HD as FAT - do you use it on Windows machines as well?

I never recommend apps like Kext Wizard, as they can cause more problems than they are worth...especially apps that attempt to modify the System folder and extension and framework files. That being said, the USB mounting issue shouldn't have been affected by the IO80211Family.kext, as it is purely used for Wi-Fi operations.

I think you are probably looking at either a reinstall of Mac OS X over the top of our current installation, or an erase and install to start clean. If you are running Mac OS X Yosemite, there were some known Wi-Fi issues, which is why Apple reverted back to mDNSresponder in El Capitan instead of the newer discoveryd DNS process used in Yosemite.

We'll see if we can help you through this.

C
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top