Canon Color Imageclass MF644Cdw Printer


Joined
Jan 18, 2012
Messages
78
Reaction score
1
I have a Canon Color Imageclass MF644Cdw Toner Printer because I got tired of my expensive inkjet cartridges drying up (I don't print a lot, but in volume). I bought it in Dec 2020 then fell off an extension ladder the following month (Serious Ouchie) so I couldn't lift the printer until last month. I upgraded to Monterey 12.1 several months ago.

Trying to install it, I get messages saying the printer is incompatible. I've done "due diligence" research at Canon sites. Charts of the printer at Canon don't even SHOW Monterey for this printers! I've tried a few drivers to no avail. Some connected user sites suggest "work-arounds", but generally, owners of new Canon printers seemed pretty pissed... I have reconnected my older HP inkjet printer.

Hardware Overview:
Model Name: Mac mini
Model Identifier: Macmini8,1
Processor Name: 6-Core Intel Core i5
Processor Speed: 3 GHz
Number of Processors: 1
Total Number of Cores: 6
L2 Cache (per Core): 256 KB
L3 Cache: 9 MB
Memory: 16 GB
System Firmware Version: 1715.60.5.0.0 (iBridge: 19.16.10647.0.0,0)
OS Loader Version: 540.60.2~89
Hardware UUID: 23EED48F-1547-5606-A8D2-9BCDC170DD84
Provisioning UDID: 23EED48F-1547-5606-A8D2-9BCDC170DD84
Activation Lock Status: Enabled

So, right now, I have have 3 questions:

1. Does anyone know how to connect the printer to Monterey?
2. I spent some time upgrading apps to Monterey several months ago, but would it just be better to revert to Big Sur or earlier?
3. Do I just have a $400 doorstop?

Cavebear
 
Ad

Advertisements

Ad

Advertisements

Joined
Jan 18, 2012
Messages
78
Reaction score
1
Sorry for the delayed response. I thought I had email notification ON and I didn't get one, so thought there was no reply.

The driver may or may not work. It downloads fine and it seems to install OK, but I can't seem to get the 2018 Mac Mini to use the Canon Color Imageclass MF644Cdw Toner Printer. I've followed the manual instructions in careful baby-steps. I've done what the printer display screen says to do, and it even showed up in my printer list (by IP address which I looked up and entered previously) but I just can't print to it. My system preferences printer button say it is "in use, default".

I've tried it wired and wireless.

I uploaded Monterey 12.1 to 12.2 (since it said it fixed some bugs). That didn't make anything worse, but it did help either.

My HP inkjet printer works just fine.

I'm really baffled by this...

Oh, and yes it IS turned on. ;)
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top