App's can delete from Launchpad from the standard user account without admin privilege


Mar 22, 2022
Reaction score
Hi Guys,
Im using
Mac Book Pro (13 Inch, M1, 2020)
macOS Monterey (Version 12.3)

Recently I have created one standard user account Without admin privilege. However when I login into the standard user account :-
1.) I tried to delete the application from the Finder ----> application folder -----> right click "move to bin" IT WILL REQUEST FOR ADMIN CREDENTIAL ( WHICH IS CORRECT AND WHAT I WANT)

2.) I tried to open the LaunchPad -----> Drag an app to Bin ----> it will ask if im confirm want to delete or cancel -----> when I click Delete ----> app got deleted.

However when I return back to application folder in finder and found the app is missing and deleted.
( Which I feel like the front door have huge lock as the back door without a door)

To confirm on this behaviour - I switch user to admin account and checked ---> Yes the app got deleted.

Contacted apple support ---> request me to perform macOS repair installation ---> I did follow the instruction. After the OS repair installation I tested it still the same behaviour.

Can someone help me on this and share if you guys also face the same issues.

Cory Cooper

May 19, 2004
Reaction score
Hello and welcome.

I haven't come across this issue personally. Honestly, that sounds like a bug in macOS, and Apple Support would be the best folks to help, as they can escalate it to their software/engineering teams.


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question