Unable to share USB HDD to Windows PC despite having network access.


Joined
Jul 29, 2015
Messages
30
Reaction score
0
Windows 10, Macbook pro OSX Catalina 10.15.5
I have access to the Mac from Windows which shows my user folder twice and my public folder, which open OK. It also shows Mac HD disk, Time Machine disk and the USB disk and seperately a folder on that disk, none of which open. Account name is required, which I complete along with correct password. I am told I do not have access.
On the mac in Shares I have the folder from the USB added, which has read/write permissions for everyone etc.
The USB drive cannot be changed and when I 'Get Info' the only permission info is 'You have Custom Access', There is no permissions window or arrow.

Can someone suggest please, how to get access to my own disk on my own computer from another computer next to it and on the same network.
Thank you in advance.
 
Ad

Advertisements

Joined
Jul 29, 2015
Messages
30
Reaction score
0
Thank you Cory, but no it does not help, I have all that set up and do have visual between the computers and can access the Apple desktop from Windows. The problem is the HDD mentioned. I cannot make any changes to it and it does not show (in Mac) the same options as other drives, i.e. the 'you have custom access' message. There is nothing wrong with the disk, it works OK.
 

Cory Cooper

Moderator
Joined
May 19, 2004
Messages
8,414
Reaction score
322
OK, thanks.

In the Get Info window for that USB drive, does it look similar to this:
Screen Shot 2020-07-12 at 14.50.54.png

You can change permissions if you click the lock, enter your user password, then check the box next to Ignore ownership on this volume. That will disable all permissions for that USB drive.

Feel free to upload screenshots of the affected drives, so we can take a look at what you are seeing.

See if that works,

C
 
Joined
Jul 29, 2015
Messages
30
Reaction score
0
Thank you again. I am familiar with what you have suggested regarding unlocking settings etc. however you will see from the attached image why I was unable to get this working.
Also, although on Windows I can see various Mac drives, that are shared, my credentials are rejected when using the correct user name and password, but, first things first...
 

Attachments

Joined
Jul 29, 2015
Messages
30
Reaction score
0
Regarding another drive, image attached, it is set correctly but access is denied when I put correct name and password.
[Edit] I have set up another account on the mac on the disk drive for sharing it and it doesn't work either.
It should be noted that from Windows it is only external disks that I cannot access, the main user folder with everything in, is useable and also Macintosh HD.
 

Attachments

Last edited:
Ad

Advertisements

Cory Cooper

Moderator
Joined
May 19, 2004
Messages
8,414
Reaction score
322
No worries.

Your first Get Info screenshot shows a disk formatted as MS-DOS (FAT 32), which is probably why you cannot adjust macOS permissions. The second screenshot show a Mac OS Extended (Journaled) disk, which already has Ignore ownership on this volume enabled.

If you have Share files and folders using SMB enabled, I am not sure why the Resources disk cannot be accessed from Windows. Have you added the drives to the Shared Folders: section in the Sharing preference pane, and set the Users: permissions there?

C
 
Joined
Jul 29, 2015
Messages
30
Reaction score
0
Do I understand correctly from your comment that a Fat32 drive cannot be shared? The idea of using Fat32 was because it is used with Windows directly and with the mac.
Rearding 'Resources'
I have since ticked the box for share on the Get info and I also did have it in shared folders. The disk is visible in windows but refuses to give access via my own admin account or via a new account I set for windows access with a different name and password, both accounts are read/write and the Resources belongs to the Staff Group. I can however open Apple-1 the main disk and Macintosh HD without the use of network credentials.
I do not, either, understand why 'Apple-1' appears twice in Windows Network.
I can easily see the Windows disks on Mac.
Any further help would be appreciated.
Windows Network.png
Mac side.png
Mac side.png Windows Network.png
 

Cory Cooper

Moderator
Joined
May 19, 2004
Messages
8,414
Reaction score
322
Hello,

I think you can share FAT 32 disks, but you just don't have the same permissions, since they aren't using a Mac disk format.

It may be showing Apple-1 twice because it has multple share points enabled.

Unfortunately, I don't have a lot of experience with Windows as I mentioned previously, but I do know that it is much harder to access files on a Mac from a Windows machine than Windows files on a PC from a Mac.

I will ask a few colleagues next week, who are "Windows" folks.

C
 

Cory Cooper

Moderator
Joined
May 19, 2004
Messages
8,414
Reaction score
322
No worries...

I will let you know if I find additional information about this issue.

C
 
Ad

Advertisements

Joined
Jan 20, 2014
Messages
39
Reaction score
4
Not sure if this has anything to do with it or will be helpful but with thumb drives I have noticed that formatting to FAT-32 gives a different result when done on a Windows machine than it does on a Mac. You would think they would be the same but apparently they are not. When a thumb drive is formatted to FAT-32 on a Mac it is not recognized by a Windows machine, though I am not sure if this is still the case in the newer Mac operating systems using APFS. So my question for you is, was the external drive formatted on a Windows machine or a Mac?
 
Last edited:

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top