SD Card not mounting

Discussion in 'Mac Notebooks' started by Solemax, Jan 6, 2017.

  1. Solemax

    Solemax New Member

    Joined:
    Jan 6, 2017
    Messages:
    1
    Likes Received:
    0
    Hello everyone,

    I'm having some issues mounting an SD card on my 2016 MacBook Pro via a USB-C SD Card reader. The problem is that the card does not mount at all, it doesn't show up in disk utility or system report either. So I'm reaching out to see if any of you might have an idea of how to fix this.

    I've done the following troubleshooting:
    • SMC & NVRAM Reset.
    • Checked finder settings to show all items on desktop
    • Checked disk utility and system report to see if card is recognised
    • Tried importing via image capture and Adobe Lightroom
    • Card reformatted via my Nikon camera (exFAT) and also via Windows 7 (exFAT) and 'SD Formatter' from the SD association (exFAT)
    • Card (Sandisk Extreme Pro UHS-1) is not faulty - Is recognised by Nikon camera and Windows 7 laptop.
    • Reader & Mac are not faulty - My secondary SD card (Lexar UHS-1) mounts without any issue.
    • Both SD cards mount without any issue on a Windows 7 laptop and in my camera. The primary card however (Sandisk) refuses to work in any Mac, I was at the Apple Store and tried mounting it on an MacBook Air and older MacBook Pro which have a built in SD card reader.
    • Only difference between the cards is SDXC 64Gb 95mb/s (Sandisk) vs SDHC 16Gb 95 mb/s (Lexar)
    • Spoken to the manufacturer of the card reader and there should be no issue with SDXC cards.
    • Spoken with apple and there should be no issue with SDXC cards.
    The only thing I can conclude is that either the reader is faulty and for some reason it reads my Lexar card but not my Sandisk card, or the Mac is not compatible with the Sandisk card.

    Any insights would be much appreciated.

    Edit: I just tried connecting the camera directly to the Mac and it recognises the SD card via Image Capture but not on the desktop. Faulty SD card reader or messed up Mac settings?
     
    Last edited: Jan 6, 2017
    Solemax, Jan 6, 2017
    #1
    1. Advertisements

  2. Solemax

    Cory Cooper Moderator

    Joined:
    May 19, 2004
    Messages:
    5,000
    Likes Received:
    141
    Hello and welcome.

    Sorry we didn't get back to you sooner. I see you made some progress - getting it to be recognized in Image Capture. It could simply be that your Mac isn't setup to show external drives on the Desktop: Finder > Preferences... > General > Show these items on the desktop: uncheck and check the box next to External disks.

    Let us know if that helps,

    C
     
    Cory Cooper, Jan 8, 2017
    #2
    1. Advertisements

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Similar Threads
  1. snfitz

    External hard drive not mounting

    snfitz, Jan 30, 2008, in forum: Mac OS X
    Replies:
    0
    Views:
    3,058
    snfitz
    Jan 30, 2008
  2. thor

    External HD not mounting after improper removal

    thor, May 14, 2008, in forum: Hardware and Peripherals
    Replies:
    2
    Views:
    1,361
  3. raggio
    Replies:
    0
    Views:
    128
    raggio
    Aug 14, 2006
  4. raggio
    Replies:
    1
    Views:
    148
    raggio
    Aug 26, 2006
  5. Hugh Browton

    When is a SIM card not a micro-SIM card?

    Hugh Browton, Jun 21, 2010, in forum: UK Macs
    Replies:
    7
    Views:
    352
    Martin S Taylor
    Jun 23, 2010
  6. D Sharp

    SD card in wrong slot

    D Sharp, Jul 24, 2016, in forum: Introductions
    Replies:
    3
    Views:
    412
    Cory Cooper
    Jul 27, 2016
  7. Brian Davidson

    My SD card is empty now?!?

    Brian Davidson, Sep 3, 2016, in forum: Mac OS X
    Replies:
    5
    Views:
    499
    Cory Cooper
    Sep 5, 2016
  8. JMC

    Mac Pro 2013 Won't Read SD Card

    JMC, Oct 9, 2016, in forum: Mac Desktops
    Replies:
    4
    Views:
    587
    oldscribe
    Oct 9, 2016
Loading...