Macbook Pro only boots into single user mode


Joined
Dec 2, 2014
Messages
1
Reaction score
0
My son’s summer 2011 15-inch MacBook Pro running Mavericks stopped booting up. We can only get a blue, black, or white screen while trying all of the following:
  • Booting into safe mode: bar only filled halfway before white screen
  • Booting while holding option: no matter what I choose (all tried during separate boots), Mac HD, Recovery, or Install disk that I put in disk drive—all resulted in white screen or blue screen with vertical lines.
  • Booting for Netboot using an N, the globe spins and the bar fills all the way to the end before screen goes white/blue. Option-N give us a blinking globe--then to white screen.
  • Booting with Cmd C did not force the mac to read the disk drive.
  • Booting with a D did not go into the Apple Hardware Test
  • Reset prams using Cmd/Option/P/R numerous times—did nothing.
  • Verbose mode—didn’t give us any errors.
WE ARE ABLE to get into single user mode.

I made a bootable Mavericks installer on a usb jump drive from my 13-inch macbook pro (we’re both using Mavericks). His computer would not read the drive, and when the jump drive showed up in Option boot, we clicked on it and it resulted in a white or blue screen.

I messed with it for an entire day; finally removed and replaced the hard drive. I got in once using Option and choosing Recovery and was able to reinstall Mavericks in disk utility. At least my son was able to get all files off that he needed. This only lasted for 2 days before the mac reverted to its previous behavior.

I finally found the following to try in Single User mode, since that is the only boot we can use with success:

/sbin/fsck –fy /
/sbin/mount –uw /
mkdir /Disabled_System_Library_Extensions
cd / Disabled_System_Library_Extensions
mv /System/Library/Extensions/ATI* .
mv /System/Library/Extensions/AMD* .
touch /System/Library/Extensions
exit

This worked perfectly and I was able to get in! But I wanted to do a clean install by wiping out the HD in Disk Utility and then doing a Network Recovery, so that I would get an OS X that came with the computer. I wanted to start all over.

But, I couldn’t boot up any other way than going into Single User mode and typing in the above—therefore, I couldn’t get into OS X Utilities. After booting up that way 3 times trying to figure out how to do a clean install, I ran into other trouble:

Now when I try to go into Recovery mode, my only options are OS X Install and Recovery HD. His Mac HD is no longer showing up, and both those choices do not work—goes to white/blue screen.

Verbose mode starts and flashes off halfway through.

I can’t use anything in Single User mode—the root# prompt has been replaced with –sh-3,2#

Most commands return “no such file or directory,” or “command not found.” If I run fsck –fy / it says everything is ok. If I run mount -uw or uaw / I get a bazillion lines saying “disk2s2: device is write protected.” With “[ErrType IO] and [ErrNo 13] under each, among other things. If I try to use cd\ it says HOME not set.

I tried some commands without running mount –uw, but still got all kinds of errors noted above. I have googled and tried everything I could find on the internet.

I would really like to wipe out the HD and go back to factory settings. Anyone have any ideas?
 
Ad

Advertisements

Joined
Sep 17, 2014
Messages
4,855
Reaction score
237
Since you want to start at the beginning with the new drive, you can boot your "problematic" 2011 15-inch MacBook Pro in Target Disk Mode, together with your good 13-inch macbook pro. The way this would work is as follows:

1. Make sure both machines are off.

2. Connect the two machines via a Firewire 800 cable (I believe both of those machines have Firewire 800 ports).

3. Boot up the 13-inch macbook pro.

4. While holding down the T key, boot up the 2011 15-inch MacBook Pro.

Your new hard drive inside the 2011 15-inch MacBook Pro will show up on the 13-inch macbook pro's desktop. From there, you can use Disk Utility on the 13-inch macbook pro to complete wipe off the new hard drive inside the 2011 15-inch MacBook Pro. Just make sure to choose the "longest" way of doing that, so that the hard drive is COMPLETELY empty. I'm not sure what that looks like in Disk Utility in Mavericks, as I am running Yosemite, but via Disk Utility in Yosemite, clicking on the icon for a hard drive, then clicking on Erase, then clicking on Security Options, a screen is presented with a slider, with Fastest on the left end, and Most Secure on the right end. The choice would be Most Secure. That will take quite a bit of time, partially depending on the size of your hard drive.

Once that is done, you can use Disk Utility to partition the drive (if needed). Then, run the Install OS X Mavericks file on the 13-inch macbook pro to install a "virgin" Mavericks on that drive/partition (I believe it is best to have another copy of the Install OS X Mavericks file in another location on the 13-inch macbook pro. Do the same once you get your other machine up and running). If the version of Mavericks that's installed is anything less than OS 10.9.5, you need to download and install the OS 10.9.5 Combo Updater. You can get that from here:

http://support.apple.com/kb/DL1760

You can apply that updater either while in Target Disk Mode, or after installation of Mavericks, boot up the 2011 15-inch MacBook Pro, and download and install the Combo Updater there.
 
Last edited:
Ad

Advertisements

Joined
Dec 3, 2014
Messages
15
Reaction score
0
Sorry I thought it was a different problem I did not read carefully. I do not have an an answer to this question. :eek::eek:
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top