SOLVED Macbook air fails boot after 3rd party driver


Zhareck

New Member
Joined
May 10, 2019
Messages
2
Reaction score
0
Hello!
Yes, i feel stupid and would now appreciate any help!

I was trying to get a Xbox 360 controller to work on a Macbook air thats 3-4 years old. I realized I need a driver and it seems only 3rd party drivers are available.

What i did:
I installed the following driver: https://github.com/360Controller/360Controller/releases/tag/v1.0.0-alpha.2
And restarted.

Result:
The Macbook air boots, sounds the boot sound, shows the Apple logo with loading bar. The bar loads to about 60% then stops and stays. I waited for 20 minutes and then turned it off.

What I tried:
1 safe mode boot. Result: It boots and the bar that earlier went to 60% now goes to what looks like 100% and stays there. I turned off again after 20 minutes.
2 i did hardware test boot by pressing "D" key. Result: It returned only that the battery is getting older.
3 i did "command + option + R + P" keys boot to clear PRAM. Result: screen flashed and rebooted and issue is still there.

I have not tried factory restore yet. If that is the last option, is there a way to save some documents that was not backed up yet?

Thank you for any help!

Edit: I am reading the issues conversations on the drivers github page in search of solutions.
 
Last edited:
Ad

Advertisements

Ad

Advertisements

Cory Cooper

Moderator
Joined
May 19, 2004
Messages
6,944
Reaction score
242
Hello and welcome.

Glad you found a solution, and thanks for letting us know.

C
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top