iPhoto - can't play uploaded video clips

Joined
Nov 18, 2005
Messages
7
Reaction score
0
I'm not sure if this is the right place to put this thread or not, but I think it is.

Ok, I'll try to explain it clearly.

I uploaded some photo's and short video clips (mostly around 15 seconds each) to my power book using iPhoto, then because I'd JUST finished sorting through my hundreds of photo's and putting them into their correct new folders, I moved the newly uploaded photo's and vids from the iPhoto folder they went into automatically to a new folder, which I made temporarily on the desktop so I'd know where it was. I then went into that folder that was on the desktop, and clicked to preview them all. When I'd been doing this with other sets of files earlier on, a preview window would pop up and show me all the photo's in the chosen file, and also quicktime would open a window for each video clip in the folder. But ALL of the files in this new folder seem to be saved as JPEGs and it showed all the files as images, none as video clips (over half of them were vids)
When I look in iPhoto at my 'Last Roll' the 23 files are shown, and the video's have a little camcorder symbol and the length of the clip along the bottom of the preview, but when I click or double click on one, it doesn't open the file in quicktime or anything else, but it does show 'Quicktime' in bold in the menu along the top of my screen next to the apple symbol. So if I go into the Quicktime menu and open a file, I can choose one of these new videos (I also have put them back in iPhoto now, because I thought that might help, it didn't) and it opens, but when I press play it doesn't last any amount of time, it's just wizzes through the bar across the bottom and shows the clip as one image.

It might be really obvious.. I might be really stupid.. but can anyone help? I'd like to be able to play the video's, the images are fine.

I wouldn't be bothered if I hadn't deleted them from my camera after uploading them (I know it was stupid)

Nicola.
 

Ric

Joined
May 14, 2004
Messages
4,260
Reaction score
5
Hi Nicola,

if you open one of the files from QuickTime Player does it play properly ?

regards

Ric
 
Joined
Nov 18, 2005
Messages
7
Reaction score
0
I just checked.
If I go 'open file' and open one of the ones I just uploaded, it doesn't play, it just seems to be an image.

But if I open an old vid clip, it play fine, for 15 secs, so it's not a problem with Quicktime I don't think.
 

Ric

Joined
May 14, 2004
Messages
4,260
Reaction score
5
Is it the same for them all ?

Do you know which ones are which...try viewing the folder as list and look at the sizes, if you find a large one...try changing the name and adding .mov on the end (unless you camera normally names them .avi ?)

regards

Ric
 
Joined
Nov 18, 2005
Messages
7
Reaction score
0
Yeah I know which ones are vids.
I changed a couple which I know are vids not photo's and changed them to mov at the end, which makes them open in quicktime instead of a preview.. but they still only play as an image.
 

Ric

Joined
May 14, 2004
Messages
4,260
Reaction score
5
What size are they ? Send me one if you want, that may be easier ?

(e-mail address removed)

regards

Ric
 
Joined
Nov 18, 2005
Messages
7
Reaction score
0
Ok, I just emailed one. It's only 28KB, there are some that are as much as 456kb, but I know this 28KB one is absolutely definetly a video clip. I left this one as a JPEG.
 

Ric

Joined
May 14, 2004
Messages
4,260
Reaction score
5
Thanks got it...

Try searching on your Mac for another file with the same name, just in case they are any where else, I will see what I can do with this file. No luck so far !

As long as you don't take any more pictures/videos on you camera, the images and movies should be able to be recovered. Even though you have deleted them they will still be on the card...you will however need some software to recover the info !

depends on how much you 'need' them !

Download a demo of this and have a go...http://www.datarescue.com/photorescue/

The matchsticks propping my eyes open are failing now...if this doesn't work I'll gladly have another go in the morning, unless someone else jumps in to lend a hand...

regards (goodnight)

Ric
 
Joined
Nov 18, 2005
Messages
7
Reaction score
0
I tried to download that software, but I didn't get how it worked. It downloaded a file called 'wizard.sit' and I couldn't find a search tool to search all my files, though i don't think it's anywhere else anyway, but I'm half asleep, thanks for your help, I'll try again tomorrow night and I'll comeback on here.
 

Ric

Joined
May 14, 2004
Messages
4,260
Reaction score
5
Hi Nicola,

the file you downloaded was the PC version, I have put the file you need below.

Once you have it, if you are not sure what to do let me know and I'll show you...

regards

Ric
 

Attachments

  • Photorescue.zip
    677.3 KB · Views: 476

Ric

Joined
May 14, 2004
Messages
4,260
Reaction score
5
Hi Nicola,

If you aren't happy doing this, then another way would be to plug the camera back into the Mac and then goto Applications --> Utilities --> Disk Utility and then make a Disk Image of the 'Card' and send that to me, I have a lot of very good software for recovering data...

regards

Ric
 
Joined
Nov 18, 2005
Messages
7
Reaction score
0
Hi. I downloaded that software, and it found my photos and vids, and it has a small window with a list of the files and their sizes, but there's nothing to click on, what do I do now?
 
Joined
Nov 18, 2005
Messages
7
Reaction score
0
I think I'm just gonna forget about them and try not to mess anything up on the memory card with the majority of videos. I mean it's not vital I have them, I think I was just rather pee'd off coz I don't get what happened. But thanks for all your help though.x
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top