unable to delete a file whatever I do


Joined
Jul 21, 2020
Messages
1
Reaction score
0
Hey, everybody
I'm going crazy with this
I have plugged an external HD on my macbook and am trying to delete some stuff there are 2 folders that wont delete no matter what. I've had the same problem with the same folder in a BKP HD, I had to format that one so that the trash would be empty again. I cannot do the samething with this one bc i dont have enought storage space to make a backup.

I've tried everything: sudo rm -ri -rf -r none of them worked. I've tried moving the file to temp folder, nothing there either.
When I tried the sudo rm command I got the message : directory not empty
when I try to empty the trash I get: file in use error

Pls help me?
I'm running High Sierra on a macbook pro from late 15.
Both the external HDs are formated on ExFat

Thx.
 
Ad

Advertisements

Cory Cooper

Moderator
Joined
May 19, 2004
Messages
8,464
Reaction score
323
Hello and welcome.

Part of the issue may be that the drives are formatted as ExFAT. Do you use them with Windows PCs? If not, I would suggest copying the data to another drive, then reformat them as GUID - MacOS Extended (Journaled), if they won't be used as a startup disk.

You mentioned you don't have enough space on another drive to make a backup, so you may need to navigate fully into each directory/folder in Terminal, delete all files in them, then delete the directories/folders when they are empty. Also, you might want to disable Spotlight on the drives while you are addressing the issue.

C
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top