MacBook Pro mid-2014 SSD intermittent failure


Joined
Jan 5, 2021
Messages
2
Reaction score
0
Hi all,

Long-term mac user, first post.

As the title suggests, I'm trying to fix a pal's MBP, Model no A1502.

Recently his stock SSD has been failing intermittently, with it sometimes booting up, lasting ten minutes and then switching off again. After that, boots would show the flashing folder with the '?'.

I swapped the SSD through Amazon, buying an OWC model and followed the instructions to a tee on iFixit.
Catalina installed perfectly and the system worked similarly perfectly for 5-6 hours before turning off and then not booting again - encountering the same intermittent problem with sometimes booting but most of the time showing a flashing '?'.

During one of the stable boots, I managed to update to Big Sur.

It's now packed in, again!

Any recommendations? My thinking is that as the same problem occurred with both the old and new SSDs that it might be the pin receiver rather than the drives? I cleaned this gently with a toothbrush and it did seem to have some residue that was loosened. Or could it be some replaceable wiring?

Any help would be useful. The system works perfectly when operational.

The system also boots perfectly from an external USB every time but he is a musician and so this isn't a long-term solution.

Thanks in advance!
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top