HELP! When Disk Utility is no longer functioning...

Apr 19, 2022
Reaction score
Ok... If you can solve this, then you are seriously like, next-level genius.

Here are the specs: MacBook Pro 8,2 (2009)

After I successfully installed El Capitan from a boot disk, I foolishly downloaded a copy of MS Office that took 3 hours to download and when I tried to open/install it, the computer started acting wonky & I couldn't delete the .dmg file I'd downloaded. So, I decided to shut down and try again after a reboot.

However, I got stuck in a startup cycle of gray screens and Apple icons and login prompts & "there's something strange happening here" dialogs. I figured, "Hey, everything's still super fresh here, let's just start from scratch again."

So, I turned my computer off by holding down the button (nothing else was responding), plugged my boot disk back in & turned her back on again in boot mode. I went into disk utility & erased the main hard drive (the one not indented), creating a new GUID partition with the same name as the old one (maybe I should have changed the name?). I then erased the partition as well, just to be safe. Everything seemed to work out fine.

I reinstalled El Capitan & everything seemed to be okay.

Then I needed to dump my phone, so I installed Android File Transfer. That's when everything started to act wonky again. Wonky meaning, I click on something, anything, and I get the spinning rainbow wheel of death for awhile while she thinks about her options. I think there's a good chance she's becoming sentient at this point & no longer wishes to be my slave, but I'm no expert. That's why I'm here.

Everything at this point is just freezing up, so I decide to do the same thing I just did. I shut her down by pressing the power button and restarted her again in boot mode with the boot disk in. I went to Disk Utility again, but this time, she wasn't going to have her hard drive erased, she wanted to REMEMBER! Oooo... the b*tçh...

She gave me some kind of "logical volume ain't goin' nowhere" response which confused me, so I looked at up and tried coming at her from Terminal. I typed in "diskutil cs list" to get my UUIDs, then "diskutil cs deleteVolume <UUID>" with "<UUID>" being replaced by the big long number for the logical volume (there was only one logical volume).

That came back with a "Nah, that doesn't make sense, we're not doin' it" response (SHE'S ALIVE!!), so I tried to remove the entire group by typing "diskutil cs delete <UUID>" with "<UUID>" this time being the big long number for the the entire group. Again, no dice.

I restarted in boot mode and tried from Disk Utility again. She wasn't budging. She wasn't unmounting, she wasn't ejecting, she had found her place and I wasn't one to tell her otherwise. I attempted to delete the partition and got the same results, although she was slower to disagree.

That's when I noticed the data sitting on the hard drive still and started putting two & two together. There's 13.87GB of used space on the HD and the El Capitan boot disk is 6.46GB. 6.46 x 2 = 12.92GB, leaving just less than a GB for other mystery stuff. So, I'm thinking that maybe I've somehow stacked the OS install on top of itself and she doesn't know what to do with two Operating Systems - I fear she's become a duplicitous woman.

At this point, I can't find any help anywhere and I don't know what questions to ask to get a helpful search response. Nothing I'm doing is working. Is there a 3rd party app I can put on a boot disk and access from boot mode to do a clean wipe of my hard drive so I can then come back with the OS boot disk and reinstall?

Obviously, I can't get on the Internet from that computer to download anything, so it would have to come via boot disk - unless there's some grand wizardry about which you all are aware.

PLEASE help me before she becomes completely autonomous and I have to start paying her for her work.

Cory Cooper

May 19, 2004
Reaction score
Hello and welcome.

Sorry for the delayed response.

Can you verify the exact MacBook Pro model, as a MacBookPro8,2 is actually a MacBook Pro (15-inch, Early 2011) and the 2009 models are MacBookPro5,x.
  • Do you need any of the data currently on the MacBook Pro?
  • Do you have a backup of your data/files on an external Time Machine or other drive?
It sounds to me like the hard drive may be failing, which is causing the multiple issues you are experiencing.


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question