DPP4 Quits on Opening


Joined
Jun 3, 2020
Messages
12
Reaction score
1
Digital Photoprofessional 4
I have tried to download DPP4 on to an iMac running High Sierra 10.13.6
It downloaded OK but unexpectedly quits on opening
Killed it off and tried again but same thing
The pop up notice says
do you want to reopen its windows again. If you choose not to re open its windows you may have to open and position the windows yourself. dont know what that means or how to do it
I have got a version of DPP4 running an old MacBook Pro but it doesnt seem to want to know High Sierra
 
Ad

Advertisements

Cory Cooper

Moderator
Joined
May 19, 2004
Messages
10,558
Reaction score
449
Hello,

The system requirements listed on Canon's website for Digital Photo Professional 4 are:

Macintosh
OS (operating system) Mac OS X 10.8 to 10.9
Model PC with one of the above OS preinstalled
* Upgraded machines not supported
CPU Core 2 Duo 2.0 GHz or higher (recommended Core i series or later)
RAM (memory) 2.0 GB or more of RAM (4.0 GB or more recommended)
Hard disk drive Installation: Min. 200 MB of available space
Operation: Min. 256 MB of available space
Display Resolution: XGA (1024 x 768) or more (1600 x 1200 or more recommended)
Colors: 16 bit color (65536 colors) or more

I would guess the software may be too old to be compatible with macOS 10.13.6 High Sierra. It would be best to contact Canon Support to see if there is known workaround, or if there is a newer version that would be compatible.

C
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top