Desktop Behavior


Joined
May 17, 2014
Messages
4
Reaction score
0
How do I set up my desktop so that icons can be moved around on the desktop. I can't move anything.
 
Ad

Advertisements

Cory Cooper

Moderator
Joined
May 19, 2004
Messages
8,588
Reaction score
329
Hello and welcome,

First off, what version of Mac OS X? Shouldn't matter, just in case the directions below aren't the same.

You can set the Desktop to arrange icons manually using View Options in Finder.

1. From the menu bar in Finder, click on View.
2. Click on Show View Options.
3. A window labeled Desktop should open, if it is labeled something else, click on the Desktop once.
4. At the bottom under Arrange by: select None for infinite arrangement, or Snap to Grid for manual arrangement aligned with grid spacing.

C
 
Joined
May 17, 2014
Messages
4
Reaction score
0
Hello and welcome,

First off, what version of Mac OS X? Shouldn't matter, just in case the directions below aren't the same.

You can set the Desktop to arrange icons manually using View Options in Finder.

1. From the menu bar in Finder, click on View.
2. Click on Show View Options.
3. A window labeled Desktop should open, if it is labeled something else, click on the Desktop once.
4. At the bottom under Arrange by: select None for infinite arrangement, or Snap to Grid for manual arrangement aligned with grid spacing.

C
Thanks... 10.6.8 on early McBook Pro. Have done this. Have tried all Desktop settings in View Options. Icons still snap back to original positions when I try to move them. Restart computer but Nothing...
 

Cory Cooper

Moderator
Joined
May 19, 2004
Messages
8,588
Reaction score
329
Have you tried deleting the Desktop preferences plist file and restarting?

Macintosh HD > Users > youruser > Library > Preferences > com.apple.desktop.plist

Try that and let me know if it "sticks."

C
 
Joined
May 17, 2014
Messages
4
Reaction score
0
Have you tried deleting the Desktop preferences plist file and restarting?

Macintosh HD > Users > youruser > Library > Preferences > com.apple.desktop.plist

Try that and let me know if it "sticks."

C
Thanks, Cory. Deleted plist. (I know it changed the Desktop because the background changed!) BUT, the icons still snap back to their positions. Again tried all settings in View Options with no luck. Icons still immovable...
 

Cory Cooper

Moderator
Joined
May 19, 2004
Messages
8,588
Reaction score
329
OK...

Try deleting com.apple.finder.plist in the same location. Also, you could try repairing disk permissions first using Disk Utility, then deleting the plist file.

C
 
Ad

Advertisements

Joined
May 17, 2014
Messages
4
Reaction score
0
Repaired disk permissions - Restarted - tried all options in View - NO GO - Deleted Finder plist in Library Prefs - restarted - Tried all options - Still no workie. A little vexing...
 

Cory Cooper

Moderator
Joined
May 19, 2004
Messages
8,588
Reaction score
329
Hmmm..it is vexing! ;)

You could try this:

-Open Terminal app
-At prompt type cd Desktop then press Return key
-At next prompt type rm .DS_Store then press Return key
-Delete both of the files you deleted in our previous steps, then restart

C
 
Joined
Jul 21, 2007
Messages
1,252
Reaction score
15
Hello,
you can also try control/clicking on the Desktop, clicking on show view options then selecting arrange by "none".
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top