Cannot Type Special Characters On Keyboard Anymore?

Joined
Sep 13, 2015
Messages
10
Reaction score
0
Hello, everybody! Over the years I've figured out how to solve, either by researching or tenacious fiddling and experimenting, virtually all of my problems on the mac but this one doesn't seems to have any info posted about it online. Ever since forever I've just used "Option + e" to get the tilde on top of my e, or "Option + Command + 'insert key'" for other special keys. Now that doesn't work anymore :<? Any help on getting that back? I know the most recent OS X versions have just had you press down any key key and wait for the available accents popup, but I disabled that because it seems unnatural to be not be able to repeat a key.

So, any advice on getting these shortcuts to work again? I will be very indebted and thankful to the one that answers my question.
 

Cory Cooper

Moderator
Joined
May 19, 2004
Messages
11,106
Reaction score
496
Hello and welcome.

-Which version of OS X?
-How did you disable it?
-Have you tried Restore Defaults in the Keyboard preference pane?
-Do you have the Keyboard & Character Viewer enabled to show on the menu bar?

C
 
Joined
Sep 13, 2015
Messages
10
Reaction score
0
-I am fully updated with Yosemite.
-I forget the short command, I found it somewhere online after extensive searching but will hunt it down if nothing else ends up working.
-Restore defaults only seems to reset any keyboard shortcuts back to their default states; how would that be relevant to making accents?
-Yes, I enabled it, thinking it would help, but it hasn't.
 

Cory Cooper

Moderator
Joined
May 19, 2004
Messages
11,106
Reaction score
496
That is strange. It does sound like a software setting somewhere in the Keyboard preferences pane.

-Which model Mac?
-Built-in or external keyboard? If external, Apple?
-Maybe the Modifier Keys... setting in Keyboard > Keyboard prefs?

C
 
Joined
Sep 13, 2015
Messages
10
Reaction score
0
-Macbook Pro Retina Early 2013.
-Obviously built-in.
-The modifier keys window looked all right, but I restored the defaults there and nothing changed.
 

Cory Cooper

Moderator
Joined
May 19, 2004
Messages
11,106
Reaction score
496
-Do you have MouseKeys enabled in Accessibility?
-Is the Keyboard > Input Source the correct language?
-In Keyboard Viewer - are there any key "stuck" down?
-Using Character Viewer, can you double-click any of the characters and have them insert properly?
-Do you have any USB keyboard you can connect to see if the issue persists with it?

We'll keep at it,

C
 
Joined
Sep 13, 2015
Messages
10
Reaction score
0
-No
-I have unicode currently as the keyboard.
-Doesn't seem like it.
-All of them can be inputted anywhere just fine.
-Don't have any usb keyboard on hand unfortunately.
 

Cory Cooper

Moderator
Joined
May 19, 2004
Messages
11,106
Reaction score
496
Unicode Hex Input is what you have selected in Keyboard > Input Sources? That may be the problem...try changing it to one of the English keyboards - US/US Extended/British depending on where you live. I bet that will allow it to work properly.

C
 

Cory Cooper

Moderator
Joined
May 19, 2004
Messages
11,106
Reaction score
496
No worries...life gets in the way sometimes. ;)

This is really puzzling, but I will let you know if I think of anything else.

C
 

Cory Cooper

Moderator
Joined
May 19, 2004
Messages
11,106
Reaction score
496
I haven't forgotten about this, but haven't found any other suggestions so far. Any update from your end?

C
 
Joined
Sep 13, 2015
Messages
10
Reaction score
0
Hey, I'm back. Thanks for remembering about this issue still after all this time :); I hate it how people forget about unresolved tech issues because they just ignore them.

Well, I have not tried to do anything else regarding typing special characters again, because it seemed so esoteric a problem, but, for some reason, it's now fixed itself! I have no idea why, but recently all I can think of is that I disabled special quotation marks in System Preferences, and just noticed it's fixed now.

This may still not be resolved, and I will report back in to summarize if I can do completely everything I used to now and what I did to maybe fix it.
 

Cory Cooper

Moderator
Joined
May 19, 2004
Messages
11,106
Reaction score
496
No worries...I always try to keep my word and follow up if I say I am going to. ;)

Glad to hear it is resolved for now...fingers crossed. If it returns, let us know and we'll pick up where we left off.

Be well,

C
 
Joined
Sep 13, 2015
Messages
10
Reaction score
0
Well, after a while, it does seem like the problem has been fully fixed. I have full functionality when it comes to special characters and have not had an issue since my last post. It seems that over time with some mac OS update came along the option in system preferences to interfere with quotation marks. Now, it seems that would not have any effect on other special character on the keyboard, but for some reason, it did. I am guessing my own couple programs that interact with the keyboard somehow caused the Sys. Pref. option to interfere with them in some weird way, and consequently disabled other things. I hope other people with similar problems will see this thread and have their own issues resolved.

Either way, thanks for all the help I was given!
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top