SOLVED Automatically select best account


PaBear

New Member
Joined
Oct 26, 2016
Messages
75
Reaction score
5
I use Mail as provided in OS, without any modifications in macOS Mojave 10.14.3 on my MacBook Pro and the equivalent on my iMac in High Sierra 10.13.6.

Under 'Mail>preferences>composing' I am offered a choice as to which address my message(s) is to be sent from.

Unless I select a specific one, the catch-all choice of "Send new messages from 'automatically select best account' always defaults to the same address. Inevitably, the one it lands on is different from the one I have used to set up the e-mail. Can lead to mild embarrassment!

Can I disable this 'auto-choice'?
 
Ad

Advertisements

Cory Cooper

Moderator
Joined
May 19, 2004
Messages
7,317
Reaction score
260
Hello and welcome,

Through El Capitan, you could select Send new messages from: Account of selected mailbox, but it changed in Sierra to Automatically select best account. I believe that still means the selected account, but I am not 100% sure. If not, then you will have to double-check the From: section when composing an email.

There isn't a way to change the defaults other than the selections you have.

C
 

PaBear

New Member
Joined
Oct 26, 2016
Messages
75
Reaction score
5
Hello and welcome,

Through El Capitan, you could select Send new messages from: Account of selected mailbox, but it changed in Sierra to Automatically select best account. I believe that still means the selected account, but I am not 100% sure. If not, then you will have to double-check the From: section when composing an email.

There isn't a way to change the defaults other than the selections you have.

C
Thanks, Cory.
I think I may float this one by the Mac help-line [to see if I can get a bite!] as it seems wrong to have to keep going back to Mail Preferences to reset the outgoing mail address.
 

PaBear

New Member
Joined
Oct 26, 2016
Messages
75
Reaction score
5
Thanks, Cory.
I think I may float this one by the Mac help-line [to see if I can get a bite!] as it seems wrong to have to keep going back to Mail Preferences to reset the outgoing mail address.
After more than 3 hours this afternoon talking to Apple Support, both by telephone and online, I think we have cracked this. All my iCloud account and email details on my Mojave MacBook Pro (2016) have been rebuilt.
So far the sending e-mail address selection is being obeyed. For most of the afternoon the 'send' address defaulted to another gmail. Only after a careful rebuild (and I hope I haven't lost any files) it seems OK.

The two Apple advisors were very patient.

I am not yet sure but I believe my older High Sierra I-mac was not being affected by this issue.
 
Ad

Advertisements

Cory Cooper

Moderator
Joined
May 19, 2004
Messages
7,317
Reaction score
260
Excellent...glad you got more "official" word. ;)

Thanks for sharing,

C
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top