Sending Mail With Yosemite


Ormond

New Member
Joined
Oct 17, 2016
Messages
208
Reaction score
9
I'm unable to send mail with Yosemite and wondered what I might be missing. The details are....

1) Setting mail sending up for the first time on this machine.

2) I can receive mail fine.

3) I can send and receive mail using the same email account on a different machine running Snow Leopard, and have been doing so for years.

I can see what works by referencing Mail on Snow Leopard, but can't replicate the settings on another machine running Yosemite.

I've tried all three suggested ports for mail sending (25, 465, or 587) and tried turning off the Macs firewall.

The error message says "connection to SMTP server failed".

And then a video pops up where President Donald Dump says the problem is, believe me folks, being caused by Crocked Hillary.

Thanks for any suggestions!
 
Ad

Advertisements

Cory Cooper

Moderator
Joined
May 19, 2004
Messages
6,937
Reaction score
242
-Who is the email provider...Apple, Gmail, Comcast, Hotmail, etc?
-If you check Mail > Window > Connection Doctor, does it show green or red dots and give an error?

C
 

Ormond

New Member
Joined
Oct 17, 2016
Messages
208
Reaction score
9
-Who is the email provider...Apple, Gmail, Comcast, Hotmail, etc?
Cox.

-If you check Mail > Window > Connection Doctor, does it show green or red dots and give an error?
Red dot.

Error says "trying to login to this SMTP account failed. Verify that username and password are correct."

I have triple checked the login/pwd, but as I recall I needed neither to send mail in Snow Leopard. After all, Cox should know who I am and that I'm a customer on their network etc.

Here's the connection log if that helps. I erased it and then rechecked, so hopefully the following represents one connection attempt.

====================================================

INITIATING CONNECTION Mar 04 20:36:02.704 host:smtp.cox.net -- port:465 -- socket:0x0 -- thread:0x60800026c800

CONNECTED Mar 04 20:36:02.884 [kCFStreamSocketSecurityLevelTLSv1_0] -- host:smtp.cox.net -- port:465 -- socket:0x6000002adbc0 -- thread:0x60800026c800

READ Mar 04 20:36:02.884 [kCFStreamSocketSecurityLevelTLSv1_0] -- host:smtp.cox.net -- port:465 -- socket:0x6000002adbc0 -- thread:0x60800026c800
220 eastrmimpo305.cox.net cox ESMTP server ready


WROTE Mar 04 20:36:02.901 [kCFStreamSocketSecurityLevelTLSv1_0] -- host:smtp.cox.net -- port:465 -- socket:0x6000002adbc0 -- thread:0x60800026c800
EHLO [192.168.0.107]


READ Mar 04 20:36:02.924 [kCFStreamSocketSecurityLevelTLSv1_0] -- host:smtp.cox.net -- port:465 -- socket:0x6000002adbc0 -- thread:0x60800026c800
250-eastrmimpo305.cox.net hello [70.171.7.104], pleased to meet you

250-HELP

250-AUTH LOGIN PLAIN

250-SIZE 28672000

250-ENHANCEDSTATUSCODES

250-8BITMIME

250 OK


WROTE Mar 04 20:36:02.927 [kCFStreamSocketSecurityLevelTLSv1_0] -- host:smtp.cox.net -- port:465 -- socket:0x6000002adbc0 -- thread:0x60800026c800
AUTH PLAIN (*** 44 bytes hidden ***)

READ Mar 04 20:36:02.953 [kCFStreamSocketSecurityLevelTLSv1_0] -- host:smtp.cox.net -- port:465 -- socket:0x6000002adbc0 -- thread:0x60800026c800
535 5.7.0 ...authentication rejected


INITIATING CONNECTION Mar 04 20:36:02.954 host:smtp.cox.net -- port:465 -- socket:0x0 -- thread:0x60800026c800

CONNECTED Mar 04 20:36:03.130 [kCFStreamSocketSecurityLevelTLSv1_0] -- host:smtp.cox.net -- port:465 -- socket:0x6080000b0920 -- thread:0x60800026c800

READ Mar 04 20:36:03.130 [kCFStreamSocketSecurityLevelTLSv1_0] -- host:smtp.cox.net -- port:465 -- socket:0x6080000b0920 -- thread:0x60800026c800
220 eastrmimpo305.cox.net cox ESMTP server ready


WROTE Mar 04 20:36:03.138 [kCFStreamSocketSecurityLevelTLSv1_0] -- host:smtp.cox.net -- port:465 -- socket:0x6080000b0920 -- thread:0x60800026c800
EHLO [192.168.0.107]


READ Mar 04 20:36:03.161 [kCFStreamSocketSecurityLevelTLSv1_0] -- host:smtp.cox.net -- port:465 -- socket:0x6080000b0920 -- thread:0x60800026c800
250-eastrmimpo305.cox.net hello [70.171.7.104], pleased to meet you

250-HELP

250-AUTH LOGIN PLAIN

250-SIZE 28672000

250-ENHANCEDSTATUSCODES

250-8BITMIME

250 OK


WROTE Mar 04 20:36:03.163 [kCFStreamSocketSecurityLevelTLSv1_0] -- host:smtp.cox.net -- port:465 -- socket:0x6080000b0920 -- thread:0x60800026c800
AUTH PLAIN (*** 32 bytes hidden ***)

READ Mar 04 20:36:03.189 [kCFStreamSocketSecurityLevelTLSv1_0] -- host:smtp.cox.net -- port:465 -- socket:0x6080000b0920 -- thread:0x60800026c800
535 5.7.0 ...authentication rejected


INITIATING CONNECTION Mar 04 20:36:03.190 host:smtp.cox.net -- port:465 -- socket:0x0 -- thread:0x60800026c800

CONNECTED Mar 04 20:36:03.363 [kCFStreamSocketSecurityLevelTLSv1_0] -- host:smtp.cox.net -- port:465 -- socket:0x6180000bb1e0 -- thread:0x60800026c800

READ Mar 04 20:36:03.363 [kCFStreamSocketSecurityLevelTLSv1_0] -- host:smtp.cox.net -- port:465 -- socket:0x6180000bb1e0 -- thread:0x60800026c800
220 eastrmimpo210.cox.net cox ESMTP server ready


WROTE Mar 04 20:36:03.370 [kCFStreamSocketSecurityLevelTLSv1_0] -- host:smtp.cox.net -- port:465 -- socket:0x6180000bb1e0 -- thread:0x60800026c800
EHLO [192.168.0.107]


READ Mar 04 20:36:03.392 [kCFStreamSocketSecurityLevelTLSv1_0] -- host:smtp.cox.net -- port:465 -- socket:0x6180000bb1e0 -- thread:0x60800026c800
250-eastrmimpo210.cox.net hello [70.171.7.104], pleased to meet you

250-HELP

250-AUTH LOGIN PLAIN

250-SIZE 28672000

250-ENHANCEDSTATUSCODES

250-8BITMIME

250 OK


WROTE Mar 04 20:36:03.392 [kCFStreamSocketSecurityLevelTLSv1_0] -- host:smtp.cox.net -- port:465 -- socket:0x6180000bb1e0 -- thread:0x60800026c800
AUTH LOGIN


READ Mar 04 20:36:03.418 [kCFStreamSocketSecurityLevelTLSv1_0] -- host:smtp.cox.net -- port:465 -- socket:0x6180000bb1e0 -- thread:0x60800026c800
334 VXNlcm5hbWU6


WROTE Mar 04 20:36:03.419 [kCFStreamSocketSecurityLevelTLSv1_0] -- host:smtp.cox.net -- port:465 -- socket:0x6180000bb1e0 -- thread:0x60800026c800
Z2F0b3JrYXRlMzA=


READ Mar 04 20:36:03.455 [kCFStreamSocketSecurityLevelTLSv1_0] -- host:smtp.cox.net -- port:465 -- socket:0x6180000bb1e0 -- thread:0x60800026c800
334 UGFzc3dvcmQ6


WROTE Mar 04 20:36:03.457 [kCFStreamSocketSecurityLevelTLSv1_0] -- host:smtp.cox.net -- port:465 -- socket:0x6180000bb1e0 -- thread:0x60800026c800
************


READ Mar 04 20:36:03.486 [kCFStreamSocketSecurityLevelTLSv1_0] -- host:smtp.cox.net -- port:465 -- socket:0x6180000bb1e0 -- thread:0x60800026c800
535 5.7.0 ...authentication rejected


INITIATING CONNECTION Mar 04 20:36:03.487 host:smtp.cox.net -- port:465 -- socket:0x0 -- thread:0x60800026c800

CONNECTED Mar 04 20:36:03.660 [kCFStreamSocketSecurityLevelTLSv1_0] -- host:smtp.cox.net -- port:465 -- socket:0x6000002adf20 -- thread:0x60800026c800

READ Mar 04 20:36:03.660 [kCFStreamSocketSecurityLevelTLSv1_0] -- host:smtp.cox.net -- port:465 -- socket:0x6000002adf20 -- thread:0x60800026c800
220 eastrmimpo210.cox.net cox ESMTP server ready


WROTE Mar 04 20:36:03.667 [kCFStreamSocketSecurityLevelTLSv1_0] -- host:smtp.cox.net -- port:465 -- socket:0x6000002adf20 -- thread:0x60800026c800
EHLO [192.168.0.107]


READ Mar 04 20:36:03.690 [kCFStreamSocketSecurityLevelTLSv1_0] -- host:smtp.cox.net -- port:465 -- socket:0x6000002adf20 -- thread:0x60800026c800
250-eastrmimpo210.cox.net hello [70.171.7.104], pleased to meet you

250-HELP

250-AUTH LOGIN PLAIN

250-SIZE 28672000

250-ENHANCEDSTATUSCODES

250-8BITMIME

250 OK


WROTE Mar 04 20:36:03.690 [kCFStreamSocketSecurityLevelTLSv1_0] -- host:smtp.cox.net -- port:465 -- socket:0x6000002adf20 -- thread:0x60800026c800
AUTH LOGIN


READ Mar 04 20:36:03.715 [kCFStreamSocketSecurityLevelTLSv1_0] -- host:smtp.cox.net -- port:465 -- socket:0x6000002adf20 -- thread:0x60800026c800
334 VXNlcm5hbWU6


WROTE Mar 04 20:36:03.715 [kCFStreamSocketSecurityLevelTLSv1_0] -- host:smtp.cox.net -- port:465 -- socket:0x6000002adf20 -- thread:0x60800026c800
Z2F0b3JrYXRlMzA=


READ Mar 04 20:36:03.740 [kCFStreamSocketSecurityLevelTLSv1_0] -- host:smtp.cox.net -- port:465 -- socket:0x6000002adf20 -- thread:0x60800026c800
334 UGFzc3dvcmQ6


WROTE Mar 04 20:36:03.742 [kCFStreamSocketSecurityLevelTLSv1_0] -- host:smtp.cox.net -- port:465 -- socket:0x6000002adf20 -- thread:0x60800026c800
************


READ Mar 04 20:36:03.766 [kCFStreamSocketSecurityLevelTLSv1_0] -- host:smtp.cox.net -- port:465 -- socket:0x6000002adf20 -- thread:0x60800026c800
535 5.7.0 ...authentication rejected


INITIATING CONNECTION Mar 04 20:36:03.767 host:smtp.cox.net -- port:465 -- socket:0x0 -- thread:0x60800026c800

CONNECTED Mar 04 20:36:03.940 [kCFStreamSocketSecurityLevelTLSv1_0] -- host:smtp.cox.net -- port:465 -- socket:0x6100000ab940 -- thread:0x60800026c800

READ Mar 04 20:36:03.940 [kCFStreamSocketSecurityLevelTLSv1_0] -- host:smtp.cox.net -- port:465 -- socket:0x6100000ab940 -- thread:0x60800026c800
220 eastrmimpo306.cox.net cox ESMTP server ready


WROTE Mar 04 20:36:03.946 [kCFStreamSocketSecurityLevelTLSv1_0] -- host:smtp.cox.net -- port:465 -- socket:0x6100000ab940 -- thread:0x60800026c800
EHLO [192.168.0.107]


READ Mar 04 20:36:03.970 [kCFStreamSocketSecurityLevelTLSv1_0] -- host:smtp.cox.net -- port:465 -- socket:0x6100000ab940 -- thread:0x60800026c800
250-eastrmimpo306.cox.net hello [70.171.7.104], pleased to meet you

250-HELP

250-AUTH LOGIN PLAIN

250-SIZE 28672000

250-ENHANCEDSTATUSCODES

250-8BITMIME

250 OK


WROTE Mar 04 20:36:03.970 [kCFStreamSocketSecurityLevelTLSv1_0] -- host:smtp.cox.net -- port:465 -- socket:0x6100000ab940 -- thread:0x60800026c800
QUIT
 

Lufbrarunner

New Member
Joined
Jan 25, 2017
Messages
395
Reaction score
17
As above, did you enable SSL? I had a similar problem with one of my email accounts incoming (POP) was ok but outgoing (SMTP) did not work, until I enabled SSL.
 

Ormond

New Member
Joined
Oct 17, 2016
Messages
208
Reaction score
9
-Does Cox have a webmail portal that you can verify your login credentials?
Yes.

-When you used port 465 did you enable SSL?
Yes.


--Have you tried your username as well as your full email address?
Yes, both.

-Maybe this will help: Restoring Cox Email Settings in Mail for Mac OS X El Capitan - it should work for Yosemite as well.
Thanks. Not sure how I missed this on the Cox site, but that sure does seem the relevant page. Carefully followed instructions to the letter, still no workie.

Doubt this will work, but I think I'll try another mail app and see if I can get that to work. If no, I guess I'll have to resort to calling Cox, which typically involves 2 hours on the phone with a script reader, and no solution. If none of that works, I'll forget about mailing from Yosemite and just use the Snow Leopard set up that's been working for years.

Thanks guys, appreciate your input. Isn't it weird that a quarter century after email become widely available millions of people are still wresting with such things?
 

Cory Cooper

Moderator
Joined
May 19, 2004
Messages
6,937
Reaction score
242
Did you use  > System Preferences... > Internet Accounts to add your Cox account, or did you add it directly in Mail > Accounts?

If you don't have any emails to save in Apple Mail, you could try:
-Delete the Cox account however you created it.
-Applications > Utilities > Keychain Access - delete any references to your Cox account or their servers in the login keychain.
-Add the Cox account using  > System Preferences... > Internet Accounts
-Launch Mail and see if it works then.

C
 
Ad

Advertisements

Ormond

New Member
Joined
Oct 17, 2016
Messages
208
Reaction score
9
Did you use  > System Preferences... > Internet Accounts to add your Cox account, or did you add it directly in Mail > Accounts?
Directly in Mail.

If you don't have any emails to save in Apple Mail, you could try:
-Delete the Cox account however you created it.
-Applications > Utilities > Keychain Access - delete any references to your Cox account or their servers in the login keychain.
-Add the Cox account using  > System Preferences... > Internet Accounts
-Launch Mail and see if it works then.
Ok, thanks, I hadn't discovered that feature yet so seems worth a try.

I realized I may have left out relevant info.

To download mail, I login in to a pop email address at my web host. (e-mail address removed)

I would send mail through that host too, but Cox won't let me. Which makes sense, they want to control all outgoing mail over their network, spam concerns etc. So in my Snow Leopard setup I send mail via smtp.cox.net, which has always worked for years.

I'm wondering if Yosemite Mail is getting confused about these two different accounts? Dunno...

I tried a second mail app, same problem, which suggests Yosemite Mail is not the obstacle.
 

Ormond

New Member
Joined
Oct 17, 2016
Messages
208
Reaction score
9
Ha, ha! So I decided to test whether I could actually send mail through mydomain.com. Yup, no problem, worked on first try. This is what I've wanted to do for years anyway. I think I'm still operating on instructions I got from Cox like ten years ago, which are obviously no longer in effect.

I no longer care about sending mail through Cox, but am still puzzled as to why it works effortlessly in Snow Leopard and not in Yosemite. But not puzzled enough to worry about it further....

Ok, next question. Which of you guys will volunteer to drive me to the nursing home for the brain transplant?

Sorry to bother you with this!!
 

Cory Cooper

Moderator
Joined
May 19, 2004
Messages
6,937
Reaction score
242
Correct, that is an important piece of info ;)

Due to increased anti-spam practices, almost all email providers prevent the sending of email by those other than customers with accounts. The email server performs a verification check on the account sending the email, and ensures the sender's email address domain matches that of the domains that are part of their DNS and/or they authorize as a relay. Of course, there are several other checks performed by the mail servers when incoming/outgoing email is presented.

Not sure anything changed between Snow Leopard and Yosemite to prevent this, but it may have worked previously since it had been working all along...but, it shouldn't have. ;)

No worries,

C
 

Ormond

New Member
Joined
Oct 17, 2016
Messages
208
Reaction score
9
Due to increased anti-spam practices, almost all email providers prevent the sending of email by those other than customers with accounts.
Yes, I hear you, but I guess I was thinking I am a Cox customer. Thus, if I send spam over their network they know who I am and can take action. This is true whether the spam were to have the FROM address of mydomain.com or cox.net.

Not sure anything changed between Snow Leopard and Yosemite to prevent this, but it may have worked previously since it had been working all along...but, it shouldn't have.
Yes, I have no evidence Yosemite Mail is the problem. The test I did with another mail app suggests it's not. All I can tell you is that I can send mail from mydomain through smtp.cox.net on my laptop (Snow Leopard) but not on my iMac (Yosemite). I have no idea why, but it no longer matters.

Thanks again!
 

Cory Cooper

Moderator
Joined
May 19, 2004
Messages
6,937
Reaction score
242
Keep in mind...your ISP and your email provider can be the same or different. If you have Cox Communications Internet, they provide Internet connectivity. They may also provide email services with a cox.net email address. However, you can still use another email provider such as gmail.com, icloud.com, yourdomain.com, etc. with their Internet service to send and receive mail. The issue comes when someone trying to send email though a cox.net outgoing email server with a yourdomain.com email address. This is a separate service than the Internet access though Cox. It will reject the outgoing email, because it is not using the SMTP account authentication for a Cox account, and the yourdomain.com doesn't match a cox.net account domain.

Does that make sense?

C
 
Ad

Advertisements

Ormond

New Member
Joined
Oct 17, 2016
Messages
208
Reaction score
9
The issue comes when someone trying to send email though a cox.net outgoing email server with a yourdomain.com email address. This is a separate service than the Internet access though Cox. It will reject the outgoing email, because it is not using the SMTP account authentication for a Cox account, and the yourdomain.com doesn't match a cox.net account domain.
I get the theory, it just doesn't match my experience.

It seems the issue is logging in to prove one's identity.

Obviously Cox (the outgoing server) won't recognize the login info for the pop account at mydomain.com. However, there are two other forms of identification. 1) I'm contacting Cox's SMTP server from one of their IPs, and 2), I can enter Cox login info in the sending server section of Mail. It seems one or both of these methods should be sufficient to prove I'm a Cox customer. But neither work in Yosemite.

In Snow Leopard however, I can mail from mydomain.com through the Cox SMTP server, and don't need to enter any Cox login info. Both my account and my wife's (different machine and OSX) have done this for years.

But, as discussed, I can now send mail from everywhere, so this is just a nerd puzzle and not a problem that needs to be solved.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top