Problems with apache


Joined
Jun 10, 2007
Messages
1
Reaction score
0
Not sure if this is posted in the right forum so if there's a more apropriate one please tell me and i'll move it.

I'm trying to get SQL to work with the inbuilt apache and php that comes with OS X, i've installed SQL and got the database running but when I perform a test I get the error message, Can't connect to local MySQL server through socket '/var/mysql/mysql.sock'...now i've installed the mysql tools and when I run the Administrator, it tells me that my .sock file is at /tmp/mysql.sock, so i'm assuming that php is simply looking in the wrong place, the phpinfo() command confirms this incorrect address.

My problem is that i've no idea how to alter this address, the ./configure command keeps telling me that there is no such file or command, whichever folder i try it in, i've tried editing the php.ini file manually all to no avail...can someone please help!!

I'm using a macbookpro and the latest version of os x apache and php and the ones which ship with os x and sql is client version 5.1.8.

Cheers
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top