Need Help Tried Everything. -


ShanonJackson

New Member
Joined
May 28, 2011
Messages
1
Reaction score
0
Hey, so basically i bought a new 140$ Steelseries Siberia v2 headset with USB VIRTUAL Surround 7.1 USB attachment (to plug jacks -> Usb adapater -> Usb Port), And i'm so ANGRY iv'e tried everything to get it working.

For starters with every headset iv'e ever owned on my mac it has come up automatically regardless of USB or Jack. but with this new headset is just dosn't want to auto detect it no matter what, iv'e tried just plugging it in using jacks. just using usb restarting computer etc. etc etc. iv'e tried looking down the cable to all possible buttons/slides/etc etc etc still not showing up. HOWEVER if i plug it in using jacks (not usb adapter virtual surround 7.1) it shows the HEADSET as a avaliable sound option but NOT THE MIC

im considering returning it but i kinda shred'ed the box open when i opened it : ( and i always hate returning stuff because of how awkward it is would really appreciate some help if anyone knows what to do

-P.S iv'e also gone to their website and they don't offer mac support however they say their headset is mac compatible. also tried downloading their headset driver from their website and its only in windows-coding.

FML :(
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top