Lion OSX Server - Working outside Library folder


johncogan

New Member
Joined
Oct 13, 2011
Messages
2
Reaction score
0
Hi

I am brand new to the Mac. I bought a 1 year old iMac and installed Lion on it with the help of a friend.

I then downloaded and installed the Lion Server from the App Store.

I tested setting up a PHP website by creating the website folder within my Public directory (Easily accessable via Finder)

as /JohnCogan/Public/Development/PHP/Testsite

and set this up in Lion Server on Port 8081 and "Store site files in" points to that folder.

Stopped/Started server and Enable PHP web apps is enabled/checked.

Problem is it seems that PHP doesnt run on this website set up as it is.

If I create a new webiste/folder under the default /Library/Server/Web/Sites/ then PHP runs fine, phpinfo() displays data.

How can I set up Lion server to allow PHP to run outside of its default area. Reason I want it like this I dislike fiddling within the terminal with SUDO each time I want to create a new development website and add files.

Any help in this regard would be great, thanks

John
 
Ad

Advertisements

Kaveman

New Member
Joined
Nov 26, 2010
Messages
3,558
Reaction score
49
If you look in your Home Folder there is a Sites folder thats where you make sites without SUDO and Terminal. You'll have to mess with Apache settings and who knows what else to change the default locations. You'll be battling OS X security all the way.

If all you want to do is run test Sites then Home > Sites is the best option.

Enable Web Sharing in System Preferences > Sharing and you seem to have worked out how to enable CGIs.
 
Ad

Advertisements

johncogan

New Member
Joined
Oct 13, 2011
Messages
2
Reaction score
0
If you look in your Home Folder there is a Sites folder thats where you make sites without SUDO and Terminal. You'll have to mess with Apache settings and who knows what else to change the default locations. You'll be battling OS X security all the way.

If all you want to do is run test Sites then Home > Sites is the best option.

Enable Web Sharing in System Preferences > Sharing and you seem to have worked out how to enable CGIs.
Thanks. That has seemed to work.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top