Internal floopy on Mac SE eject motor doesn't function


Punkyclown

New Member
Joined
Nov 10, 2017
Messages
51
Reaction score
0
Hi All, The disk on my Mac SE could not eject disks. It makes a humming noise, sort of
like trying to pass something, but nothing comes out. It Would read the floppy and load
the system. I removed both the HD and the floppy drive, separated the cage and then
tried them both alone. The HD is dead doesn't spin up or anything. After I cleaned the
floppy and then tried it, the ejector is still no go but now the drive won't even read the disk...
Just gives an X of the icon. I have another 68K mac and it can read the disk, so now I am al
a loss. Does the floppy get it's power from the drive cable? Does it need some other aspect
of the system to power it up. Obviously I need a new drive, but concerned about power.
Thanks for the help.
Brad Hansen
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top