Fast internet speeds, super slow internet.

Discussion in 'Networking' started by sector4, Jan 19, 2017.

  1. sector4

    sector4 New Member

    Joined:
    Jan 19, 2017
    Messages:
    1
    Likes Received:
    0
    Hello!

    I'm looking for some help with my network. I'd be really greatful for any advice, or suggestions as I'm stuck.

    My ISP is virgin Media, I currently have their terrible router set up in 'modem mode' which then goes to an AirPort Extreme. This has worked fine for months, until this morning when websites stopped loading - showing too long to reach or server not responding messages. This is the same across all devices (iMac, old MacBook, iPhone, iPad, old iPhone...)

    If I load a Speedtest app up on mobile data on my phone, then turn wifi on before pressing 'start test' it takes a while to get going, but gives me 75mb down and 5mb up. I get the same results with a MacBook plugged in via Ethernet to the AirPort Extreme - it takes about 10-15 mins to load the speed test page, but when the test starts it gives me the same results.

    Interestingly when testing different things, it turns out I can still play videos from the YouTube app on my iPad, without any issue.

    I have so far tried: turning everything (devices and router/modem) off and on again, checking all settings on airport utility and devices, plugging in via Ethernet and checking the modem settings, updating modem firmware, updating airport firmware, updating all devices software. I read online that it could be a DNS issue, so I checked all DNS settings, setting them to virgin medias defaults,and tried connecting to googles 8.8.8.8 both with no success. Running network diagnostics just says 'your internet appears to be working fine' everything is lit green in the airport utilities app.

    I've hunted my way around online, and can't find a solution, so good people, where do I go from here?

    Thanks for your help
     
    sector4, Jan 19, 2017
    #1
    1. Advertisements

  2. sector4

    Cory Cooper Moderator

    Joined:
    May 19, 2004
    Messages:
    5,683
    Likes Received:
    180
    Hello and welcome.

    It definitely sounds like a DNS issue, probably with the router/modem, since it happens on multiple devices.

    -Have you contacted Virgin Media?
    -Do you have access to the router's configuration page?
    -You could try to swap out the current router/modem.

    C
     
    Cory Cooper, Jan 21, 2017
    #2
    1. Advertisements

  3. sector4

    iMav New Member

    Joined:
    Jan 13, 2017
    Messages:
    50
    Likes Received:
    0
    Location:
    Columbus, Wisconsin
    Have you plugged a Mac directly into the ISP router (which is in modem mode)? The Mac will grab a public IP and this will allow you to test with the Airport out of the picture.

    If all works fine, you can safely assume there is something amiss with the AirPort Extreme.
     
    iMav, Jan 24, 2017
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.