After installing Mountain Lion my iMac boots into a shell


Robert James

New Member
Joined
Aug 1, 2012
Messages
2
Reaction score
0
I installed Mountain Lion on top of Lion and since then two out of three times I turn on my iMAC it boots into a shell. It ends with a #root prompt and if I type 'exit' then MAC OS starts up and runs without problems.

I cannot find out how to stop it doing this - any ideas anyone?

It is a late 2009 21.5 inch iMAC with 4gig RAM, and intel core 2 duo processor.

Thank you
Robert
 
Ad

Advertisements

Cory Cooper

Moderator
Joined
May 19, 2004
Messages
7,300
Reaction score
260
Try resetting the PRAM at startup:

Hold Option-Command-P-R until you hear the second boot chime. Then, after successful boot, go to Apple Menu > System Preferences > Startup Disk and make sure your internal is highlighted.

Let us know if that doesn't fix it.

Resetting your Mac's PRAM and NVRAM
 

Robert James

New Member
Joined
Aug 1, 2012
Messages
2
Reaction score
0
Hello Cory,
Thank you very much for that advice.
It does indeed appear to have fixed the problem. I did as you said and then tried a few shutdowns and boot ups and each time it has booted correctly into MAC OS.

Thank you again for your help - it is very much appreciated!

Kind regards
Robert
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top