Two Days of Horror with my late 2012 Mac Mini!


honestone

New Member
Joined
Sep 17, 2014
Messages
4,855
Reaction score
237
Over the weekend, I had something really strange happen with my late 2012 Mac Mini, and I think it would be both beneficial and informative if I describe what happened, and how I (finally!) resolved the problem.

First, a little bit of history. I purchased my late 2012 Mac Mini in July 2013. It has a 2.3 GHz Intel Core i7 processor, 4 gig of RAM, and originally came with a 1 TB, 5400 rpm internal hard drive. The machine has always worked fine, although in November 2013, I took out the 1 TB drive, installed a 256 gig Samsung 840 Pro SSD, and installed the 1 TB drive in a slim, external case. The SSD of course flies in comparison to the 5400 rpm drive, and the 1 TB drive, in the external case, serves me well, especially when I travel (I have a number of movies and TV series on it, and I always make a SuperDuper! backup of my 2013 13" MacBook Air on a partition on the drive before we travel).

I believe quite a few folks know that I am very, very conscientious about the maintenance and upkeep of my machines. I keep them "lean and clean", always up to date with the latest software, and make it a weekly habit of doing disk maintenance/repairs, and backing up, both of my machines. The tools I use are Onyx, TechTool Pro, and SuperDuper! (along with rebuilding Microsoft Office's database). Also, I am using the latest version of Yosemite, 10.10.4. And, I am extra, extra careful with downloads.

Last Friday, I performed my usual weekly tasks for both of my machines. I followed my normal procedure, and everything seemed fine. But, starting Saturday morning, my Mac Mini began behaving in a strange manner. First, it would take somewhat longer to start it up from the SSD. Also, it would take longer to shut down. Then, on Sunday morning, it would not boot up at all, and i got the infamous Apple Question Mark on the screen. Fortunately, I have a Thunderbolt to Firewire 800 adapter, so I was able to boot the mini to Target Disk Mode for viewing the drive on my Mac Book Air. No matter which tool I used, I could not find anything seriously wrong with the SSD inside the mini. I subsequently used Disk Warrior to 1) Repair permissions, 2) check out all the files, and 3) rebuild the directory. All of that went fine.

When I rebooted the Mini, initially it booted from the SSD OK. But, then the issue (question Mark) started again! So, I took the SSD out of the mini, installed it in that slim external case (temporarily removing the 1 TB drive (very, very easy to do)), and connected it, via USB 2.0, to my Mac Book Air. Once again the SSD was fine. I even used Disk Utility to 1) Erase the drive (3 passes, and that took about 4 hours), 2) partitioned it (1 partition only), 3) did a fresh installation of Yosemite, and 4) usedMigration Assistant to migrate all my non-system files from the backup I had completed two days earlier to the SSD. I even booted the Air from that SSD, and it worked fine.

So, I put it back inside the mini, and turned the machine on. But, it would not boot from the SSD! Fortunately, it did boot from the bootable backup I had made two days earlier (SuperDuper! is great, and definitely a life saver!). Yet, the SSD would not show up at all, not on the desktop, not through Disk Utility, etc. I thought I was going to have to purchase a new machine. But, I then remembered how the SSD is connected to the motherboard inside the mini. So, this morning, I opened up the Mini, reconnected (firmly!) the SSD via the connector to the mother board, and things now work fine!

I did recently turn the mini upside down a couple of times, to re-secure the back circular cover, and i am guessing that doing that caused the connector from the SSD to the mother board to come loose.

So, hopefully this will be useful information for everyone. And, another excellent example of why backups are so, so important! They sure saved me quite a bit of grief!
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top