Problem Connecting to Airport Extreme wireless with Belkin USB Adapter

Jan 28, 2008
Reaction score
Okay, I've searched far and wide for answers to my problem, and either I have a very unique problem, or I'm just not searching wide enough.

Okay, here are the specs:

Computer: Apple Clamshell iBook
OS: OS 10.3 Panther (Thats all it says when I open the "About this Mac" thing. No 10.3.9 or anything...)
Router: Multiple Air Port Extremes (I live in a dormitory, there's about 8 routers.)
Wifi thingy: Belkin Wireless G Plus MIMO USB Wireless Adapter, Version 4.000

The Problem:
My laptop is obviously too old to have a wireless card put into it (or so I've been told..) and I searched high and low for a USB adapter that is Mac compatible. Finally, I gave in and fessed up $50 for a Belkin.

After I installed everything and plugged it in, nothing would happen. No blinking lights, my network status didn't recognize the plugin, the Belkin Utility showed me no networks.

Finally, I got online and found some drivers, downloaded, restarted, the whole shin-dig. After that, I was able to connect. The Belkin utility said I was connected to Dorm Quad 2 West (my wing) and so I excitedly opened Firefox, and it said there was no internet connection. I looked back at the utility, and it said I was disconnected. I haven't been able to get it to connect since.

This is what happens:

I restart my computer. Before I even try to connect, I look at my network status, this comes up:

When I click on it to look at it, the IP address is something like whatever. I KNOW from previous experience that an IP beginning with 169 isn't really an IP, just the computer putting something random in, pretty much.

The Belkin Utility opens automatically, I try to connect:

I click "Connect", input the network password, click "Ok" and I sit there, and nothing happens. Nothing. At. All.

I look in my "profile" tab, and click on the best one, click "activate", and that yellow/red checkmark comes up. When it was connected, the red turned green. As long as I wait, nothing happens:

I look BACK at my network status, and now Ethernet(en1) is gone, and can only be found in the dropdown menu:


Absolutely nothing appears in it. There were random numbers in the blanks before. I tried hitting "Renew DCHP Lease" and still nothing happens.


Any ideas, anyone?

I tried downloading that... chipset thing that starts with a Z (I'm blanking at the moment...) and installing the WLan utility, but when I open the utility, there's no networks visible and I can't click on the dropdown menu, even though the en1 says "active".

The button is yellow, though, and it says something like "The en1 is active, but it has a self-assigned IP address and may not be able to connect to the internet".

I got it to turn green once and connect to a neighbors wireless for like, five minutes. But it was only like, 20% connection and all I could do was use Google.

Please help? I know I'm not terribly computer savvy when it comes to these kinds of things... other things I'm really good at, though! hahaha.

Maybe I'm really close to doing it right and I just need someone to explain it a different way than what I've found.
Jan 30, 2008
Reaction score
I've had the same problem on my G5 computer.
No luck yet though...hopefully someone will have an answer to this issue ASAP.


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question