iMac G4 "Flashing Computer Screen" after new HD installation

Joined
Mar 23, 2021
Messages
1
Reaction score
0
Greetings,
We pulled out our 2002 iMac G4 and connected an external storage device (WD My Passport for Mac) to move files before attempting to sell the machine. When I cam back to the computer a few hours later, I found the "flashing question mark in the computer screen." When restarted, that screen is all we got. Preliminary investigation suggested that the external device threw the computer into kernel panic and that the HD was fried. We purchased a new HD and installed it (interesting process). The same "flashing...screen" appears. I want to reload OSX 10.1.5 from the original installation discs to the machine and sell it since we have all peripherals (keyboard, mouse, speakers, owners' manual, discs, box...all of it). Any help to rectify our issue would appreciated. PLEASE NOTE: I am not a computer savvy dude with experience in computer repair so any advice would need to be written for the lowest denominator, i.e. myself. Thank you very much.
 

Cory Cooper

Moderator
Joined
May 19, 2004
Messages
11,084
Reaction score
490
Hello and welcome.

Sorry for the delay in responding.

-Is it an iMac (Flat Panel) or iMac (17-inch Flat Panel)?
-You mean the original gray restore discs, correct? If so, what is the part number on the discs?
-Are you starting up while holding the C key down, so you can choose the Restore Disc to startup from?

Those old "iLamp/Luxo Jr." G4 iMacs have a very specific, fairly involved, repair process. You need to re-apply thermal paste and torque the screws in a particular order and to a particular torque setting, or it can overheat and damage other internal components.

C
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top