SOLVED Color of Visited Links


Joined
Aug 29, 2014
Messages
37
Reaction score
0
I'm unsuccessfully trying to find a way to change the color of links that have been visited in Safari. Also, I would LOVE to be able to change links on youtube to videos I've watched to a different color or somehow mark them as watched. Very frustrating. I can't believe there's not an extension for this. I tried the text editor thing but it only got me a Firefox icon on my desktop?????? Nothing in Safari preferences where I could choose it. I'm using OS 10.15.7 with Safari 15.6.1. Can anyone help? Thanks!
 
Ad

Advertisements

Joined
Jan 25, 2017
Messages
1,166
Reaction score
87
Launch a Text Editor application on your Mac, and click "Format" in the main menu. Choose "Make Plain Text" if available.


Type "a:visited { color: (color) !important; }" in a new text file with (color) being the color that you want visited links to be. Replace "(color)" with the code of the corresponding desired color. For example, if you want visited links to be green, type "a:visited { color: #00FF00 !important; }" in the text file.


Click "File" in the main menu bar, and then click "Save As." Name the file "color.css" and save it to your desktop. Click the "Use .css" button in the dialog box.

Open Safari, choose "Preferences." Click the "Advanced" tab. Click the "Style Sheet" drop-down menu and select "Other." Navigate to the "color.css" file you saved in. Highlight it and click "Choose."

Restart your browser and your visited links will now be the color you designated.
 
Joined
Aug 29, 2014
Messages
37
Reaction score
0
Thanks but this is what I tried that I described in my post. The only difference is that I was told to name the file "CustomLinkColor.css" and I got the results I described. I tried it again, using your nearly identical instructions but when I went to save it, it wouldn't let me change the extension to "css". Thanks anyway. I don't know why this has to be so hard.
 
Joined
Jan 25, 2017
Messages
1,166
Reaction score
87
If you are using TextEdit do you have Plain text encoding set ?
To save with .css extension try unticking 'If no extension is provided, use .txt.'
 
Joined
Aug 29, 2014
Messages
37
Reaction score
0
Yes, I do have it set to plain text. When I try to save it as .css. it says "You cannot save this document with ".css" at the end of the name. The required extension is "rtf". You can choose to use both so that your file name ends in ".css.rtf". I guess this is because when I try to save it the box that comes up says "Rich Text Document" in the file format space (even though it's not). The available extensions offered are: html, odt, docx, .xml, and .doc. I turned on "make plain text" yesterday when I first tried this and it's still set that way. When I look at format the only thing there is "make rich text" but it's grayed out.
 
Ad

Advertisements

Joined
Aug 29, 2014
Messages
37
Reaction score
0
For anyone else who may be having this problem with Safari, I found a quick, easy solution: Download and use Firefox as your browser. You only have to go to the settings and choose your colors. EASY PEASY!!!! Even works on youtube!!! In 2022 things like this shouldn't have to be so hard!
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top