Global assign Open With problem


ju stme

New Member
Joined
Sep 9, 2017
Messages
4
Reaction score
0
I have recently upgraded to OS X 10.12. I have several webloc files on my desktop all showing the Safari icon. I have declared Vivaldi as my default browser in System Prefs as well as Vivaldi. I can do a standard right click, Open with and am able to select a bunch of different apps, one of which is Vivaldi. Safari, however, shows at the top of the list.

When I invoke the Get Info Pane, I see the Open with area greyed out and am unable to access the drop down list.

Back to Right click, Open with. If, instead of selecting Vivaldi, I choose other, Firefox, Chrome, Vivaldi are all greyed out unless I enable All Applications. Then I can choose Vivaldi and click Always Open With, which results in a warning in the Choose Application window: "It's not known if this application can open [filename]." Pressing on, I click on Open.

The file opens. However, a system message: "You can't change the item [filename] to always open in the selected application. The item is either locked or damaged, or in a folder you don't have permission to modify (error code -10823)."

I have repaired permissions. I have dragged new URLs onto the desktop. I have run Onyx. I have checked for viruses, malware. I have rebooted, zapped PRAM, pulled the plug. (I don't have enough hair left to pull out, though if I did, I would by now surely be hairless!) I am out of ideas.

Help?
 
Ad

Advertisements

Cory Cooper

Moderator
Joined
May 19, 2004
Messages
7,318
Reaction score
260
Hello and welcome.

I just installed Vivaldi to test, and my Mac is acting the same as yours. I don't believe you can change the default Open with for webloc files. They will automatically open in whatever browser you select in  > System Preferences... > General > Default web browser:, but you cannot manually assign an app from the Get Info dialog. I would guess it's due to the new security protocols in OS X.

Hope that helps,

C
 

ju stme

New Member
Joined
Sep 9, 2017
Messages
4
Reaction score
0
Hello and welcome.

I just installed Vivaldi to test, and my Mac is acting the same as yours. I don't believe you can change the default Open with for webloc files. They will automatically open in whatever browser you select in  > System Preferences... > General > Default web browser:, but you cannot manually assign an app from the Get Info dialog. I would guess it's due to the new security protocols in OS X.

Hope that helps,

C
Hello, Cory, and thanks for the response. At least I know I'm not crazy.

Pre 10.12 install, those webloc files were created from Firefox. After the install, I guess the default browser was assigned as Safari with no input from me and cast in stone. Doesn't seem right somehow that it cannot be changed. However, I guess I can and will have to live with the new and "improved" OS.
 
Ad

Advertisements

Cory Cooper

Moderator
Joined
May 19, 2004
Messages
7,318
Reaction score
260
No worries.

Just chalk it up to ever tightening security...something we unfortunately don't have control over.

;)

C
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top