Website does not work


activeOAP

New Member
Joined
Mar 11, 2019
Messages
2
Reaction score
0
I am using OS 10.9.5 and Safari 9.1.3 hooked up to Virgin. All of my top sites work fine except for one - skiset.co.uk which opens but does not respond to clicks at all. Is this my problem or theirs?
 

Cory Cooper

Moderator
Joined
May 19, 2004
Messages
6,309
Reaction score
216
Hello and welcome.

It loads fine on my iMac running macOS Sierra and Safari 12.0.3. I suspect it may be due to the age of you software, specifically Safari. Have you tried using Chrome or Firefox?

I will find a Mac running Mavericks and see if I can replicate the issue, and I will update this thread when I have more information.

C
 

Cory Cooper

Moderator
Joined
May 19, 2004
Messages
6,309
Reaction score
216
OK, I loaded that site on Mavericks 10.9.5 with Safari 9.1.3. Responds normally.

It sounds like it may be something in Safari, especially if another browser loads the page normally. I would try Safari > Reset Safari > check all boxes. Also, check if you have any Safari Extension installed and loaded in Safari > Preferences... > Extensions.

Also, do you happen to have Adobe Flash installed?

C
 

activeOAP

New Member
Joined
Mar 11, 2019
Messages
2
Reaction score
0
Thanks for your help. I will be away next week but will revisit problem when I come back . Query - the world seems to be driven by system/ app updates, what if you like an old version ?
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Similar Threads


Top