Strange pink and green pixels


edvideo

New Member
Joined
Feb 11, 2015
Messages
2
Reaction score
0
I have a late 2009 iMac desktop. When I turn it on it starts normally but after a little bit of time it freezes, and pink & green pixels appear on screen in patterns. The cursor can be moved but does nothing. I just had my hard drive replaced a few months ago and keep everything on an external hd. I haven't been able to find any info online. Hopefully someone out there has some. Thanks.
 
Ad

Advertisements

Cory Cooper

Moderator
Joined
May 19, 2004
Messages
7,318
Reaction score
260
Hello and welcome.

That is usually a sign that the video card/logic board (depending on the exact model) is failing. Unfortunately that can be an expensive repair as that iMac is out of warranty at this point. If you have an external monitor you can hook up, try that. If the issue happens on the external as well, it is definitely the video card/logic board. If it doesn't, then it may be just the LCD panel, which is also an expensive repair.

Hope that helps,

C
 
Ad

Advertisements

honestone

New Member
Joined
Sep 17, 2014
Messages
4,855
Reaction score
237
I was thinking something similar to what Cory mentions. Surprisingly, I have had my Sony 19" External monitor since February 2004, and it still works flawlessly (I'm using it on my Mac Mini, and that is where I am typing this)!
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top