Screenrecorder doesn't record audio only video


Alfettaracer

New Member
Joined
Dec 1, 2017
Messages
19
Reaction score
0
Probably after an SW update, but since a while I cannot make a screen recording with Quicktime (10.5) anymore.
I used to put the audio input and output (with system preferences) on Soundflower (2ch) If I record for instance a YT video then during recording no sound, but after the recording I switch audio output on USB PnP Sound Device and play back works with sound (on my external amp with loudspeakers)

This worked fine for a long time. I checked the forum for issues with sound flower. For now I don't want to install/download a separate screen recorder.
I red on a Mac website how easy it should be to make a screenrecording with QT. I checked this forum for Soundflower issues (rather complicated to read how to find and de- install the files)

Is Soundflower not compatible anymore (on my Macbook Pro 2012 with OS 10.14.5) ?
Strangely enough I couldn't find the program in my program folder (also not in the help programs. Also Clean MY Mac de -installer couldn't find it). So I decided to download Soundflower again. But the same problem after a QT screen recording only video no sound. But now I can find the program in my Applications Folder. But I cannot open the program only the read me file etc. (see attachment). Any advice of hint will be appreciated! Because I am stuck. Gerard (NL)
 

Attachments

Ad

Advertisements

Cory Cooper

Moderator
Joined
May 19, 2004
Messages
7,306
Reaction score
260
Hello,

It may depend on the version of Soundflower you are running. Cycling '74 was the original author of Soundflower. Rogue Amoeba acquired it in 2014. Ultimately, they decided against further development , and the original author Matt Ingalls acquired it back at the end of 2015. He now releases new versions at his GitHub site: mattingalls/Soundflower. It looks like the latest version is 2.0b2, and can be found here.

Try downloading and installing that, and see if works then.

C
 
Ad

Advertisements

Alfettaracer

New Member
Joined
Dec 1, 2017
Messages
19
Reaction score
0
I used the script for de-install of the "old sound flower" version on my Mac. I went to this website and managed to install the version you mentioned.
The results are however the same: only video is recorded with QT screen recording but no audio.
as an experiment: I went to system preferences and selected Audio and choose input internal microphone and for output internal speakers. (I don't know if this makes sense as an experiment to check things) but with recording a piece of a YT video I have sound while recording, but with playback only video. I wanted to figure out if making a screen recording is possible without sound flower. (I did playback something from my iTunes library to check my system/speakers. This was not a problem iTunes gives audio with the speakers of my Macbook Pro. Further assistance is welcome. I wil check this thread today again, thx in advance.G.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top