Quick Action - passing rich text?


clambin

New Member
Joined
Sep 22, 2019
Messages
2
Reaction score
0
I'm trying to create a quick action to email a selected part of a Numbers spreadsheet. However, if I try to pass "rich text" (select Workflow receives current ...), the quick action doesn't show up in the Services menu. If I just select "text", it does show up but obviously passes unformatted text to the email, which isn't readable.
 
Ad

Advertisements

Cory Cooper

Moderator
Joined
May 19, 2004
Messages
7,264
Reaction score
259
Hello and welcome.

-Which version of OS X/macOS?
-Which version of Numbers?
-Are you creating an Automator Workflow? If so, can you give us the steps and/or post a screenshot?

C
 

clambin

New Member
Joined
Sep 22, 2019
Messages
2
Reaction score
0
Hi.

Using the latest macOS (10.14.6) with Automator Version 2.9. I don't think the version Numbers is important, as I can reproduce the same behaviour with other apps (as soon as I set it to "rich text", the quick action no longer shows in the Services menu), but for what it's worth, I'm on Numbers version 6.1 (6369).

I'm not creating an Automator Workflow: I'm building a Quick Action so that the action is available on the Services menu:


Screenshot 2019-09-22 at 22.50.42.png



Works well if I set the input to just "text". But it disappears from the Services menu when I set it to "rich text".
 
Ad

Advertisements

Cory Cooper

Moderator
Joined
May 19, 2004
Messages
7,264
Reaction score
259
OK, thanks.

I am not to well-versed with Automator, but I will test it on my Mac and get back to you. Maybe Quick Actions cannot process rich text the same as plain text?

C
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top