MAC won't play videos


Joined
Mar 16, 2015
Messages
6
Reaction score
0
Hi,
I wonder if anyone can help? I have Quicktime, Peri, VLC Player, DivX and none of them will play mp4's, AVi's or anything video related. My flash player is up to date and plays youtube videos no problem. I am using Yosemite if that's any help? I'm a bit of a novice so any help would be much appreciated. It's such a pain!!
 
Ad

Advertisements

Joined
Sep 17, 2014
Messages
4,855
Reaction score
237
What specific Mac model are you using? Also, make sure you have the latest version of VLC media player, version 2.2.0. You can get it from here:

http://www.macupdate.com/app/mac/5758/vlc-media-player

By the way, I am not having any issues at all playing mp4s, AVI's, etc. on both of my machines, and I am also running under the latest version of Yosemite, 10.10.2. And, of course, I use VLC, as it can handle just about any video format.
 
Joined
Mar 16, 2015
Messages
6
Reaction score
0
It's a Mac book pro (13-inch, Early 2011)
2.3 GHz Intel Core i5

I have deleted VLC playing and am currently downloading again from the link you suggested, will let you know how i get on. Thanks!
 
Joined
Mar 16, 2015
Messages
6
Reaction score
0
still no luck, I have updated VLC player to the up to date, when i drag it and drop it onto the cone on my dock it opens VLC, it appears in the playlist but the duration says 00:00 and won't play
 
Joined
Sep 17, 2014
Messages
4,855
Reaction score
237
Really strange you are having issues. Up until a couple of seconds ago, I always started VLC first, then did an Open File, navigated to the folder that contained the video I wanted to see, and selected it, and it has always worked. But, I just tried your method by taking the first episode of Season 1 of Tyrant, dropped its AVI file onto the VLC icon in the dock, and it worked.

Right now, I am at a loss as to why you are having this issue. Maybe someone else can give you some advice/help.
 
Last edited:

Spawn_Dooley

Moderator
Joined
Jun 13, 2007
Messages
2,855
Reaction score
93
Strange issue, do you have another user account you can try for comparison's sake? Where are the mp4/avi files from? A movie camera or phone?
 
Ad

Advertisements

Joined
Mar 16, 2015
Messages
6
Reaction score
0
The USB had corrupted the files when sending them over, thank you for you're help! Glad to have it sorted!
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top