I just can not get my Yamaha PSR E413 to connect to my MacBook Pro/Logic 9


Joined
Jul 20, 2012
Messages
2
Reaction score
0
Hi,

I would be so grateful if someone can help me in as basic detail as possible. About a year and a half ago I bought a MacBook Pro with Logic 9 in the hope of connecting my Yamaha Keyboard to it and making music. I have so many songs just waiting to be made!

However, despite trying all sorts of ideas over the last year and a half, I can not get it to connect or make sound or anything at all. All the posts I read seem to be closely related but don't make much sense to me. I would like to act as though I have never done this before and just get it going. It's really getting me down that I can't do it. I know that I can make the music when it's connected or will learn fast but I just can't get it working.

I have:

MacBook Pro
Logic 9
Yamaha PSR E413
USB wire
Audio wire
iMic

I want to be able to play the keyboard and have it set up info in tracks so I can play with it in Logic.

Fingers crossed! Thanks :-D
 
Ad

Advertisements

Cory Cooper

Moderator
Joined
May 19, 2004
Messages
8,414
Reaction score
322
Hello and welcome. Sorry we didn't get back to you sooner.

A couple of questions:

-Do you want to use the built-in instruments/sounds of the Yamaha or the ones in Logic?
-Have you tried it in GarageBand also?
-Did you connect it via the USB-MIDI cable and/or a standard audio cable?
-Have you downloaded and installed the Yamaha USB-MIDI driver?
-What version of Mac OS X are you running?

We'll try to get you up and running with the above information.

C
 
Joined
Jul 20, 2012
Messages
2
Reaction score
0
Hi and thank you for coming back to me.

I have now resolved the issue. I was using the correct usd midi cable and the right software had been downloaded etc... I wanted to use the sounds in Logic rather than from the keyboard.

I took my keyboard and laptop to a music studio. They showed me that the midi was being picked up because on the bottom bars of the main Logic screen it was showing as keys being touched when I played the notes. The problem was no sound was being picked up. The studio said they have encountered this before. All I needed to do was open Logic before I connected the cable. By connecting the Yamaha keyboard to the laptop before Logic was open, for some reason it was not picking up on the sounds (!) but it is now easily sorted. For some reason, every now and again whilst using Logic, it will stop playing the sound which is quite annoying. However, a quick save and restart seems to sort this.

Thanks again for the response.

Ian.
 
Ad

Advertisements

Cory Cooper

Moderator
Joined
May 19, 2004
Messages
8,414
Reaction score
322
Not a problem Ian, just glad it's sorted. Thanks for posting the fix too!

C
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Similar Threads

PSR file ext conversions 1

Top