Ghostscript, Scribus $ High Sierra


Joined
Oct 22, 2017
Messages
8
Reaction score
0
I have been using Scribus for a couple of years now, and would like to download Ghostscript to:
a} use the print preview function
b} to stop the Ghostscript warning appearing every time I open a new file!

I have downloaded various versions of GS, with and without installer, on the net, and found various instructions on how to install......none which seem to work!
GS 9.22 appears to be the latest version, but when I transfer the opened file to the Terminal, I cannot get it to connect.
Does anyone have some up to date info on getting these 3 programs to talk to each other?
Thanks
Nick
 
Ad

Advertisements

Cory Cooper

Moderator
Joined
May 19, 2004
Messages
8,750
Reaction score
334
Hello and welcome.

I am not familiar with Scribus or GhostScript. It looks like the current version of Scribus for Mac OS X is 1.4.6 for Lion or higher - their website incorrectly lists Lion as 10.8, which is actually Mountain Lion. There doesn't seem to be a GhostScript release for Mac (UNIX) on their website? Also, the Scribus Wiki states you should install GhostScript before you install Scribus, or you will get an error message that GhostScript isn't installed.

Did you you try the steps from the Scribus Wiki - OS X - Installing Scribus on your Mac the easy way?

Because High Sierra was just released, and there were numerous changes to the System itself, there may be compatibility issues with High Sierra and Scribus/GhostScript.

C
 
Joined
Sep 17, 2014
Messages
4,855
Reaction score
237
Because High Sierra was just released, and there were numerous changes to the System itself, there may be compatibility issues with High Sierra and Scribus/GhostScript.

C
That point made by Cory is so, so accurate! As it is, there are a number of apps for which 1) it is questionable whether the latest release of such apps will work with High Sierra, and 2) there are some apps which are still being tested with High Sierra, with no update yet. Case in point: the excellent disk cleanup/maintenance/repair program Tech Tool pro, which I depend upon (along with at least 5 other programs). I have been in touch with the good folks at Micromat (developers of Tech Tool Pro, and they have bene very honest and up front with the issues they are having in trying to develop an update for High Sierra compatibility. Last year, Micromat was not able to release a version of Tech Tool Pro that would be compatible with Sierra until November (of last year).

Another app for myself which?might? need an upgrade for High Sierra compatibility is the Logitech Control Center software for Logitech devices (I use two Logitech mice). The reason I say "?might?" is that last year was the first time I had seen Logitech release a version for Sierra compatibility.

I did read on another Mac discussion site that Apple will be releasing the first update to High Sierra, OS 10.13.1, real soon. But from what I read, it is not "correcting" anything critical. In fact:

"The latest macOS High Sierra beta, build 17B42a, appears to contain only minor bug fixes and performance improvements, according to Apple's release notes.".
 
Last edited:
Joined
Oct 22, 2017
Messages
8
Reaction score
0
Hello and welcome.

I am not familiar with Scribus or GhostScript. It looks like the current version of Scribus for Mac OS X is 1.4.6 for Lion or higher - their website incorrectly lists Lion as 10.8, which is actually Mountain Lion. There doesn't seem to be a GhostScript release for Mac (UNIX) on their website? Also, the Scribus Wiki states you should install GhostScript before you install Scribus, or you will get an error message that GhostScript isn't installed.

Did you you try the steps from the Scribus Wiki - OS X - Installing Scribus on your Mac the easy way?

Because High Sierra was just released, and there were numerous changes to the System itself, there may be compatibility issues with High Sierra and Scribus/GhostScript.

C
Thanks, Cory - the one link that has made any sense so far is the one you sent me -Scribus Wiki - OS X - Installing Scribus on your Mac the easy way?-- Ghostscript is now working as a Print Preview, but the quality is very poor....as you mentioned, Ghostscript/ Scribus/ High Sierra are probably not yet compatible. But, at least, the error messages have ceased!
Nick
 
Ad

Advertisements

Cory Cooper

Moderator
Joined
May 19, 2004
Messages
8,750
Reaction score
334
No worries.

Glad to hear it is partially resolved...thanks for letting us know.

C
 

Top