Simulate a VGA monitor connected to a computer?

Discussion in 'Video Hardware' started by notme, Jul 16, 2009.

  1. notme

    notme Guest

    Apparently different video drivers are loaded depending on if a monitor is
    connected or not. This is the case when connecting via VNC to a "headless"
    Mac Mini.

    Using just a Mini-DVI-to-VGA adapter won't load another driver.

    Is there a way to emulate a monitor connection?

    Is this a case of I^2C communication? Any simpler method?

    Thanks.
    N.
     
    notme, Jul 16, 2009
    #1
    1. Advertisements

  2. notme

    Tim Williams Guest

    I think so. I can't get VGA from my laptop without I2C... when I try
    forcing it, Windows drops the data line (request, I suppose) for about 1ms,
    then it fails, not detecting anything. And I so wanted to get raw RGB+sync
    signals at the time... guess I won't be doing that, at least without
    something I2C on the line (EEPROM? uC?).

    Tim
     
    Tim Williams, Jul 16, 2009
    #2
    1. Advertisements

  3. notme

    IanM Guest

    Its a *long* time since I was digging around inside monitors but IIRC to
    fake one you'll need a 24C02 I2C EEPROM programmed with suitable VESA
    EDID data *AND* 75 ohm resistors to ground on the R B and G lines.
    Probably easiest to rob a dead CRT monitor for the EEPROM if this is a
    one off project. Otherwise you'll need to research VESA DDC2B and EDID.
     
    IanM, Jul 16, 2009
    #3
  4. notme

    JF Mezei Guest

    Not quite the same, but if you plug a VGA monitor to a MiniDisplayPort
    to VGA Adapter, the LAPTOP (13" Macbook pro) will show the second
    monitor as a VGA monitor, while it shows the Laptops's own as the
    standard LCD one.

    So it clearly detects it is a VGA monitor connected to the
    minidisplayport. Whether it used a different driver, I can't tell.

    Not sure how the newer MiniDisplayPort compares against Mini-Dvi in
    terms of the outputs. Is it just a different plug with same signals, or
    is it really very different ?


    Whether it is a different "driver" I can't tell. But the OS clearly knew
    this was a VGA output, despite coming out of a Mini-DVI port.
     
    JF Mezei, Jul 16, 2009
    #4
  5. notme

    notme Guest

    What problem are you trying to solve?

    When VNC'ing into a Mac Mini (Mini has 10.5.7), I cannot see data in Apple
    Numbers spreadsheets. They appear blank (all menus work, all features of the
    spreadsheet function -- there's just no data displayed). The spreadsheet
    prints and shows the data OK.

    The author of the VNC client tells me that it's probably because of the
    default display driver. He suggests plugging in a monitor or emulating one. I
    am moving house and have nothing (my monitors and most everything else is
    2000 miles away) other than the Mini and an old PowerBook G3/400 (w/ 10.4.11)
    that I'm using for the VNC client.

    I tried another "brand" of VNC client with the same results.

    I tried changing numbers of colors and display resolution with no results.

    not
     
    notme, Jul 17, 2009
    #5
  6. notme

    notme Guest

    notme, Jul 17, 2009
    #6
  7. notme

    Doc O'Leary Guest

    The DVI-to-Video adaptor is only $20, and I'm guessing it doesn't need
    to query a TV to provide the composite signal.
     
    Doc O'Leary, Jul 17, 2009
    #7
  8. notme

    notme Guest

    Good idea. Any favorite makes / models?

    Thanks.
     
    notme, Jul 18, 2009
    #8
  9. notme

    notme Guest

    Have you tried opening the spreadsheet in a brand-new Mac OS X user
    Spreadsheet appears identical regardless what user opens it on this Mini via
    VNC.
    No other computers available. I'm moving house and all my tools & stuff is
    2000 miles away.
    <http://i29.tinypic.com/2ebcric.jpg>

    I can access all menus and buttons on the window. Note the term "Rent" in the
    edit field just below the Format Bar. This shows the content of the current
    cell, and changes as I use the arrow keys to scroll around the (invisible)
    cells of the spreadsheet, so I know the data exists.

    Printing works as it should and shows a normal spreadsheet populated with
    data.

    Thanks.
     
    notme, Jul 18, 2009
    #9
  10. notme

    Chris Ridd Guest

    That's a pretty interesting way for Numbers to fail, and I'm wondering
    if it is using Quartz in some way that VNC isn't supporting.

    Which VNC server and client are you using? Have you tried different
    clients? (Not sure if you can run a different VNC server...)

    If you've got Xcode installed, can you run
    /Developer/Applications/Graphics Tools/Quartz Debug.app and play with
    the Disable Quartz Extreme/Enable QuartzGL menu items? I think you need
    to restart Numbers after making these changes.
     
    Chris Ridd, Jul 18, 2009
    #10
  11. notme

    Doc O'Leary Guest

    I was just talking about what the Apple Store has available. You could
    probably find cheaper at any computer shop, especially if you're not
    really going to use it.
     
    Doc O'Leary, Jul 18, 2009
    #11
  12. notme

    notme Guest

    You mean? ::

    <http://tinyurl.com/kmqcbu>
     
    notme, Jul 18, 2009
    #12
  13. notme

    Tim Murray Guest

    I saw the screen shot, and that's certainly odd. I'm thinking Quartz is doing
    something VLC doesn't like. If you have two people available, one at each
    machine, try YuuGuu or www.acrobat.com > connect now. Both are free.
     
    Tim Murray, Jul 19, 2009
    #13
  14. notme

    Chris Ridd Guest

    Have you tried different VNC clients, including Apple's Remote Desktop?
    If no clients can see your Numbers spreadsheet, then the bug's likely
    to be in the VNC server.
     
    Chris Ridd, Jul 20, 2009
    #14
  15. notme

    notme Guest

    At US$300 for ARD, I could go buy a monitor (2 or 3) to plug into the Mini
    and solve the issue.
     
    notme, Jul 20, 2009
    #15
  16. notme

    Chris Ridd Guest

    Yeah, but what about the other free clients? It mght be worth trying
    this out in an Apple Store too, if you can reach one.
     
    Chris Ridd, Jul 20, 2009
    #16
  17. notme

    notme Guest

    Both JollysFastVNC and Chicken Of The VNC give identical results.
     
    notme, Jul 20, 2009
    #17
  18. notme

    notme Guest

    Have you tried doing this yet?: Thanks for the creative suggestion.

    I just made up one tonight and plugged it into the Mini. It had an effect, if
    not the one I expected.

    When I plug in the "dummy" connector and reboot, I cannot connect to the Mini
    via VNC at all. (Tried different clients; no joy.)

    If I unplug the dummy, the mini behaves as before; VNC connectivity is
    restored.

    ???

    Thanks.
     
    notme, Jul 22, 2009
    #18
  19. notme

    IanM Guest

    Sounds like its getting stuck before the VNC server starts. Probably
    because its got a dialog box up resulting from the monitor change. Can
    you set the resolution to 640x480 via VNC and try again?


    As all ID pins open was originally defined as 'no monitor', it would
    also be worth connecting pin 11 (ID0) to pin 5 (GND) to properly
    identify your connector as a colour VGA monitor.

    I don't think grounding pin 4 (ID2) will help as I doubt the Mac
    supports IBM 8514/A displays :) It is worth a try though if you
    already have it working at 640x480 to see if you can then switch to
    1024x768.

    You *will* need the I2C eeprom if you want to emulate a higher
    resolution monitor.
     
    IanM, Jul 22, 2009
    #19
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.