Microsoft Remote Desktop vs 2 - shift key weirdness

Discussion in 'UK Macs' started by jim, Jul 24, 2008.

  1. jim

    jim Guest

    Anyone else using RDC v 2 ? If so, do you find that it doesn't reliably
    send shift-key status?

    Trying to type "A$" quite often results in "A4".

    Reverted to v1.0.3 and so far so good.

    Jim
     
    jim, Jul 24, 2008
    #1
    1. Advertisements

  2. jim

    jim Guest

    The only odd thing I was doing was RDC'ing to the work server, then
    RDC'ing from it to another machine. I wonder if v2 doesn't cope well in
    'nested' RDC environments.

    Using v1 seems fine.

    Jim
     
    jim, Jul 24, 2008
    #2
    1. Advertisements

  3. I've had that, no shift key affect at all. Went back to VNC.

    Cheers - Jaimie
     
    Jaimie Vandenbergh, Jul 24, 2008
    #3
  4. jim

    jim Guest

    FWIW this was RDC'ing to a Windows 2000 server, then from it to an XP
    box.

    I haven't tested whether the shift-key oddity was there if I was only on
    the W2K machine.

    Jim
     
    jim, Jul 24, 2008
    #4
  5. That reminds me that I've had the same problem using Apple's Screen
    Sharing (ie VNC) to a Mac in order to poke an XP running in Parallels.
    Shift state wasn't transferred to the XP vm.

    Totally different route, same result. Curious.

    Cheers - Jaimie
     
    Jaimie Vandenbergh, Jul 24, 2008
    #5
  6. jim

    jim Guest

    Fixed it. It wasn't affecting a connection just to the W2K machine, so
    it was something to do with the hop from there to the XP machine.

    On the W2K machine I changed RDC's Options->Local Resources->Keyboard to
    'On the local computer'

    This _seems_ to have fixed it.

    So not actually a Mac problem after all, but might be useful to someone.

    Jim
     
    jim, Jul 24, 2008
    #6
  7. jim

    Jon B Guest

    I could never replicate it in an excel sheet, but I reliably couldn't
    get the case sensitive password right in our BACS banking software using
    the v2 beta, and guessed as it worked fine in v1.x something wasn't
    right in v2, I reverted back too.

    I'd not tried this release, probably for the best.
     
    Jon B, Jul 24, 2008
    #7
  8. jim

    Rob Guest

    Works perfectly fine in a sluggish sort of way with work's Windows 2003
    server, and an iMac/Leopard.

    Rob
     
    Rob, Jul 24, 2008
    #8
  9. jim

    jim Guest


    Yes, the problem turned out to be with the RDC client on the W2K machine
    - looks like it wasn't consistently passing on modifier values until a
    setting was tweaked.

    Jim
     
    jim, Jul 24, 2008
    #9
  10. jim

    Jon B Guest

    Which setting was that, be useful to tweak ours.
     
    Jon B, Jul 24, 2008
    #10
  11. jim

    jim Guest

    On the W2K machine I changed RDC's Options->Local Resources->Keyboard to
    'On the local computer'

    Jim
     
    jim, Jul 24, 2008
    #11
  12. jim

    Jon B Guest

    Thanks will look into that later.
     
    Jon B, Jul 24, 2008
    #12
  13. jim

    Nick Bell Guest

    I sometimes find that CAPS LOCK status is completely reversed, i.e. if
    CL on, all lower case, and vv.

    Nick
     
    Nick Bell, Jul 25, 2008
    #13
  14. jim

    shadowwraith New Member

    Joined:
    Oct 9, 2017
    Messages:
    1
    Likes Received:
    0
    ---
    I actually do something even wierder...I login to a mac from a mac. The mac I am logging into has configured Microsoft Remote Desktop to connect to a PC.

    I too was having this problem where the shift key was not working. I don't know but it may be that the response of the system is too slow or "breaks" the continuity of simultaneously holding the shift key down and pressing a key.

    What I did was hit the shift key 5 times in succession activating "Sticky Keys" (you may get a dialog the first time you do this). So now I am able to enter the shift+2 to get @ or shift+4 to get $.

    There maybe some control panel on the client you are connecting to that will allow it to wait longer for key repeats or something along those lines, but I haven't messed with this.

    Good luck.

    p.s.
    For awhile a work around I did was to setup Teamviewer. That works without all the shift key shenaniggans.
     
    shadowwraith, Oct 9, 2017
    #14
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.