Magic Mouse: scrolling ceases to function after sleep

Discussion in 'Mac' started by JF Mezei, Nov 7, 2010.

  1. JF Mezei

    JF Mezei Guest

    Two days in a row now.

    When I get back to the Mac after many hours of sleep it takes a while
    for the Magic Mouse to work (perhaps 20 seconds ?). Eventually, the
    mouse mouvement and the click works. But the scrolling doesn't.

    I tried powering mouse off/on. No change.

    Went to the system preferences/Mouse to adjust the settings, hoping it
    would reset, no change.


    Used blue tooth to disconnect mouse. No change. Mouse is shows as
    disconnected, but is still usable.

    Went to system preferences/blutooth and deleted the Magic Mouse entry.
    That worked, but mouse still continued to work. (except for scrolling).

    Tried to add the mouse back, and the system would not find it.

    Yesterday, I had to reboot my Mac (MacPro).

    Oh, and I changed batteries too.


    Any hints on what could be wrong ? And how to fix it ?


    And out of curiosity, if the Magic Mouse were to be inoperative, how is
    one supposed to get to the system preferences/mouse and/or bluetooth to
    get it rep]aired or/reconnected or whatever ?

    Sort of ironic that one still needs a wired mouse as backup.
     
    JF Mezei, Nov 7, 2010
    #1
    1. Advertisements

  2. JF Mezei

    JF Mezei Guest

    A cursory look at the console log doesn't show anything obvious.


    So, i shut down the Mac once more, this time unplugging it and pulling
    it ouf of its slot between desks, opened it, and unplugged the internal
    bluetooth module. I suspect there may have been some conflict between
    that one and the USB dongle i need to use above the desk

    Rebooted, and was able to pair the mouse again. Scrolling works. And the
    power level was updated too. Remains to be seen if tomorrow morning the
    thing will work.

    I just wish Apple made a wired Magic Mouse.
     
    JF Mezei, Nov 7, 2010
    #2
    1. Advertisements

  3. JF Mezei

    JF Mezei Guest

    Jolly Roger wrote:

    >> A cursory look at the console log doesn't show anything obvious.

    >
    > What about the system log?



    What should I be looking for ?

    The problem has re-occured after I left my machine to watch some old
    fashioned TV for a few hours.

    Mouse works, but scrolling doesn't.

    Running Xev (in an xterm), it shows events for mouse mouvement,
    mouseclicks, but nothing for scrolling. (but this is expected if the
    problem lies at a much deeper level within OS-X).


    Since a reboot fixes it without touching the mouse, I suspect the
    problem is not with the mouse. And it is interesting that my config has
    been stabel for a while and this only started yesterday.
     
    JF Mezei, Nov 8, 2010
    #3
  4. JF Mezei

    JF Mezei Guest

    UPdate:

    In the bluetooth system preference, I deleted the mouse.

    Mouse continued to function (without scrolling).

    Tried to setup a bluetooth mouse (from the mouse system preference), but
    it found nothing.

    Physically disconnected the Bluetooth USB dongle. The Mac showed
    Bluetooth no longer available.

    Reconnected the bluetooth dongle.

    Went to the Mouse system preference, clicked on the "setup bluetooth
    mouse" and this time, it did find the mouse and the scrolling was working.

    What I find interesting is that after the sleep period, the mouse does
    work for moving cursor, and mouse clicks, but not for scrolling. If the
    system lost connection to the mouse, you'd think none of those would work.


    XEV on X windows does register events for scrolling movements. Mouse
    button 4 5 (vertical) 6 and 7 (horizontal).
     
    JF Mezei, Nov 8, 2010
    #4
  5. JF Mezei

    deshepherd New Member

    Joined:
    Dec 23, 2016
    Messages:
    16
    Likes Received:
    1
    I have the same problem now for the first time!
     
    deshepherd, May 11, 2017
    #5
    1. Advertisements

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Similar Threads
  1. Gary.Delp
    Replies:
    5
    Views:
    7,026
    BhindiBhaji
    Mar 13, 2008
  2. Des O'Donoghue
    Replies:
    0
    Views:
    317
    Des O'Donoghue
    Mar 30, 2005
  3. Des O'Donoghue
    Replies:
    3
    Views:
    185
    o-chan
    Apr 6, 2005
  4. Claude-Albert Berseth
    Replies:
    0
    Views:
    327
    Claude-Albert Berseth
    Jun 10, 2006
  5. Marc Heusser
    Replies:
    1
    Views:
    188
    Dave Seaman
    Jul 23, 2004
  6. iMike
    Replies:
    1
    Views:
    286
    Cory Cooper
    Oct 1, 2016
  7. gemini.nancy

    Scrolling limited to scroll bar only

    gemini.nancy, Oct 5, 2016, in forum: Mac Desktops
    Replies:
    2
    Views:
    391
    gemini.nancy
    Oct 9, 2016
  8. user_3000
    Replies:
    11
    Views:
    1,812
    honestone
    Oct 17, 2016
Loading...