Any way to mount sparseimages over s3fs ?

Discussion in 'Programmer Misc' started by Geico Caveman, Jul 9, 2009.

  1. $ hdiutil create MacHD -size 50G -type SPARSE -fs HFS+ -layout GPTSPUD  
    -stretch 50G -volname MacintoshHD 
    creates a sparseimage 
    $ hdiutil attach MacHD.sparseimage 
    hdiutil: attach failed - Illegal seek 
    that I cannot mount. 
    The image is located on a fuse filesystem (Amazon S3 mounted through s3fs).

    If I create the same image on local hard disk, it mounts without any issues. 
    Geico Caveman, Jul 9, 2009
    1. Advertisements

  2. Geico Caveman

    Simon Slavin Guest

    Crossposting between different groups in the c.s.m.* hierarchy is
    forbidden. See the charter. Consider carefully which group
    isappropriate to your problem and post just there. Do not multipost.

    Simon Slavin, Jul 9, 2009
    1. Advertisements

  3. Cross posting, which he did, is preferred and just fine. get a new
    Dave Balderstone, Jul 9, 2009
  4. Did not work through Disk Utility (got an illegal seek error).

    Through command line:

    $ hdiutil create MacHD -size 50G -type SPARSEBUNDLE -fs HFS+ -layout
    GPTSPUD -stretch 50G -volname MacintoshHD
    hdiutil: create failed - Input/output error

    Now I cannot even create anything.
    Geico Caveman, Jul 10, 2009
  5. Tried that (used encryption this time - this entire business is useless

    The transfer hung at 9.1MB / 65MB or so.

    I get a popup error (used the GUI for the copy) :

    The Finder cannot complete the operation because some data in
    "MacHD.sparsebundle" could not be read or written. (Error code -36).

    This also unmounts the s3fs fuse mountpoint.


    I see a folder there (not an image icon like it was on Desktop).

    I can click on the folder to reveal a single folder named bands.

    The fact that I can get inside without any popup asking me for the
    password (I tested the original sparsebundle - that does ask for a
    password) means that the encryption is non-existent.

    Filling up the sparse image / bundle locally with Carbon Copy Cloner or
    SuperDuper! and then moving it to Amazon S3 is not an option because of
    the 5GB upload limit per entity in S3. The hard disk I am trying to
    backup is 38GB currently.

    I would not mess with any of this at all if duplicity on Mac was not
    broken. Macports has an error that prevents duplicity from being built.
    This error has been in existence for weeks, if not months. An
    intolerable situation that would have been unheard of in Linux.

    If I can't even do remote encrypted backups, this whole business is
    useless. Sorry about the rant (and you deserve none of it given how
    helpful you have tried to be), but I am getting pretty frustrated here.
    Geico Caveman, Jul 11, 2009
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Similar Threads